Skip navigation.
Home
The QNX Community Portal

View topic - SPI Driver

Page 2 of 2

Re: SPI Driver

PostPosted: Tue Dec 06, 2011 5:54 pm
by Tim
Zaheer,

What do you mean you are getting error as a memory fault.

Do you mean your program crashes? If so, run the debugger and see where.

If you mean you get an error code it would help to know what it is.

Tim

Re: RE: SPI Driver

PostPosted: Mon Oct 21, 2013 5:31 am
by Ericxx
kiddocoo wrote:Hi RanAricha,

Thanks for the help, i have managed to get the SPI working now.
The 0x00 is actually from the buffer from the previous transmit :(
Meaning i need to read back 5 bytes of data and the correct one is in the 5th byte.

If anyone needs woking SPI codes, i'll be glad to share it out :)

Regards,
Kiddo


Dear Kiddo,

I am trying to use the SPI to communicate with a peripheral sensor device. Would you mind sharing your modified SPI code with me? My email is eric.dongxx@gmail.com. Thanks a lot!

Best regards,
Eric

Re: RE: SPI Driver

PostPosted: Mon Mar 09, 2015 10:17 am
by umamahesh
Hi
I have new queries in compiling the Resource Manager driver for i2c. Following are my queries for writing new resource manager
1. Whether the project for writing new resource manager(RM) should be created as static/shared?
2. After the compiling the RM driver, where to copy *.o/*.so/*.a ?
3. Should I change any makefiles?

RIght now I using Momentics 6.5 IDE, please share the procedure in compiling and updating the IFS for writing new RM driver.
Looking for suggestions.