Skip navigation.
Home
The QNX Community Portal

View topic - no background image in Photon Window Manager (OS Image)

no background image in Photon Window Manager (OS Image)

For discussion of realtime and/or embedded programming.

no background image in Photon Window Manager (OS Image)

Postby rahil » Sun Feb 22, 2009 6:42 am

I've configured the wm.cfg file to have a background image, but pwm is not able to show the background image. It always shows black background. I've attached the build file and also the contents of the wm.cfg are as shown below.

[wm config]
fore_color = 0xD8D8D8
active_color = 0x5C8BDF
title_color = 0x65
inactive_color = 0xB1C1D9
base_color = 0xBDBDAA
border_active = 0
placement = 4
text_align = 2
auto_raise = 0
keyboard = 0
focus_cursor = 0
click_front = 1
drag = 1

[background]
vert_align = CENTER
horz_align = CENTER
image_op = PROPORTIONAL STRETCH
image = /usr/share/backdrops/1024x768/default.jpg
Attachments
cbsp-x86bios.zip
Build file.
(2.11 KiB) Downloaded 162 times
rahil
Active Member
 
Posts: 75
Joined: Wed Feb 11, 2009 12:13 pm
Location: India

RE: no background image in Photon Window Manager (OS Image)

Postby rahil » Mon Mar 09, 2009 5:12 am

This problem was due to a driver (devg-soft3d.so). I just included it in the project, and i'm able to see the backgroung image.
rahil
Active Member
 
Posts: 75
Joined: Wed Feb 11, 2009 12:13 pm
Location: India


Return to Realtime and Embedded

Who is online

Users browsing this forum: No registered users and 1 guest