Skip navigation.
Home
The QNX Community Portal

View topic - The USB PFS devices could not able to mount in the Intel tar

The USB PFS devices could not able to mount in the Intel tar

For discussion of realtime and/or embedded programming.

The USB PFS devices could not able to mount in the Intel tar

Postby g_hari79 » Tue Nov 03, 2009 11:06 am

When I insert philips PFS USB device, I am getting below error
io-fs-media(pfs): Unable to load iofs-pfs.so module (Unresolved symbols).

When I execute below command to mount pfs device, I am getting the error below is log for it.

# DL_DEBUG=1 io-fs-media -dpfs,ignore=0b951720,ignore=0b957720,debug=0,device=0:2:0,mount=/fs/pfs0 -vvvvv
# dlopen("iofs-pfs.so",256)
load_object: attempt load of iofs-pfs.so
load_elf32: loaded lib at addr b8200000(text) b821ecb8(data)
dlsym(0x806d040,_btext)=0x804b380
Library loaded; type 'add-sym iofs-pfs.so 0x804b380' in gdb to load symbols
unknown symbol: usbd_device_descriptor
unknown symbol: usbd_string
unknown symbol: usbd_abort_pipe
unknown symbol: usbd_hcd_ext_info
unknown symbol: usbd_connect
unknown symbol: usbd_alloc
unknown symbol: usbd_detach
unknown symbol: usbd_mphys
unknown symbol: usbd_attach
unknown symbol: usbd_device_extra
unknown symbol: usbd_status
unknown symbol: usbdi_sync_io
unknown symbol: usbd_select_interface
unknown symbol: usbd_reset_device
unknown symbol: usbd_interface_descriptor
unknown symbol: usbd_configuration_descriptor
unknown symbol: usbd_device_lookup
unknown symbol: usbd_disconnect
unknown symbol: usbd_free_urb
unknown symbol: usbd_free
unknown symbol: usbd_alloc_urb
unknown symbol: usbd_reset_pipe
unknown symbol: usbd_pipe_endpoint
unknown symbol: usbd_parse_descriptors
unknown symbol: usbd_setup_bulk
unknown symbol: usbd_setup_vendor
unknown symbol: usbd_io
unknown symbol: usbd_open_pipe
unknown symbol: usbd_urb_status
io-fs-media(pfs): Unable to load iofs-pfs.so module (Unresolved symbols).
io-fs-media(pfs): Failed starting pfs driver: No such file or directory(2)

QNX version = 6.4.0
g_hari79
New Member
 
Posts: 4
Joined: Tue Nov 03, 2009 11:01 am

RE: The USB PFS devices could not able to mount in the Intel

Postby maschoen » Tue Nov 03, 2009 4:35 pm

I'm going to take a wild guess that the driver is written for a version 6.3 or less and needs to be recompiled under 6.4.
maschoen
QNX Master
 
Posts: 2640
Joined: Wed Jun 25, 2003 5:18 pm

Postby g_hari79 » Wed Nov 04, 2009 5:36 am

Thanks Maschoen for your quick response.

the versions of the libraries are as below.
# use -i /lib/iofs-pfs.so
NAME=iofs-pfs.so
DESCRIPTION=Play for Sure Library
DATE=2009/05/19-02:46:42-WEDT
STATE=Experimental
GCC_VERSION=4.2.4
QNX_VERSION=640

# use -i /lib/libusbdi.so.2
NAME=libusbdi.so
DESCRIPTION=Generic USBDI library
DATE=2009/05/20-16:40:42-EDT
STATE=stable
VERSION=6.4.1
TAGID=166

# ldd /lib/iofs-pfs.so
/lib/iofs-pfs.so:
iofs-pfs.so => /lib/iofs-pfs.so (0xb8200000)
My assumption is "libusbdi.so.2" library dependency is missing to iofs-pfs.so, correct me if I am wrong.

Please let me know if details are insufficient. Could you please help me out?
g_hari79
New Member
 
Posts: 4
Joined: Tue Nov 03, 2009 11:01 am


Return to Realtime and Embedded

Who is online

Users browsing this forum: No registered users and 2 guests