Skip navigation.
Home
The QNX Community Portal

View topic - .altboot doesn't start with USB keyboard

.altboot doesn't start with USB keyboard

For discussion of realtime and/or embedded programming.

.altboot doesn't start with USB keyboard

Postby grillosolitario » Thu Aug 05, 2010 8:47 am

Hello,

I have made a QNX image for my system, but I need a second image for developing. I actually created it and saved it as .altboot. When I start the PC, the system, as you know, "asks" you to choose between .boot (doing nothing) and .altboot (hitting 'ESC' key).

If I'm using a PS2 keyboard, there's no problem: I hit 'ESC', and .altboot boots. However if I use a USB keyboard, the system doesn't answer when I hgit 'ESC', and it starts with the .boot image. I thought it could be a problem with the PC, but it is not, as long as I was able to enter the BIOS setup. Unfortunately, in the real system it won't be possible to plug a PS2 keyboard.l

Is there any way to boot the PC with the alternative image using a USB keyboard?

Thanks.
grillosolitario
Active Member
 
Posts: 91
Joined: Mon Oct 18, 2004 4:47 pm
Location: Spain

RE: .altboot doesn

Postby mario » Thu Aug 05, 2010 9:25 am

make sure the bios is setup to emulate the keyboard
mario
QNX Master
 
Posts: 4132
Joined: Sun Sep 01, 2002 1:04 am

Postby grillosolitario » Thu Aug 05, 2010 10:58 am

:oops: :oops: :oops: :oops: Thanks :oops: :oops: :oops: :oops:

<solved>
grillosolitario
Active Member
 
Posts: 91
Joined: Mon Oct 18, 2004 4:47 pm
Location: Spain


Return to Realtime and Embedded

Who is online

Users browsing this forum: No registered users and 2 guests