Skip navigation.
Home
The QNX Community Portal

View topic - Issue with shelf

Issue with shelf

For discussion of realtime and/or embedded programming.

Issue with shelf

Postby surabhi » Tue Jul 26, 2011 5:56 am

Hi,
I have an issue with the shelf utility. As all know, when shelf process is created successfully, a launch menu will be shown at the right side of the photon. The problem i faced is , when i pressed the "Windows" key from keyboard just after the log in screen , the shelf utility has got killed .I have examined the slogger log, which shows that thread 2 of shelf process exited due to Signal number 2(SIGSEGV). This problem does not exist if i pressed the "Windows" key after showing the launch menu at the right side of the photon.

I would like to know why the shelf utility exited abnormally during the above mentioned scenario.
surabhi
New Member
 
Posts: 4
Joined: Tue Apr 27, 2010 5:34 am

RE: Issue with shelf

Postby mario » Tue Jul 26, 2011 7:24 pm

What version of QNX are you using. I vaguely remember problem like this being fixed in 6.5.0.
mario
QNX Master
 
Posts: 4132
Joined: Sun Sep 01, 2002 1:04 am

Postby surabhi » Wed Jul 27, 2011 4:25 am

I'm using QNX 6.5.0 itself
surabhi
New Member
 
Posts: 4
Joined: Tue Apr 27, 2010 5:34 am

Postby mario » Wed Jul 27, 2011 3:15 pm

I guess you should contact QNX to report the bug then. But signal number 2 is NOT a SIGSEGV but a SIGINT, very different.
mario
QNX Master
 
Posts: 4132
Joined: Sun Sep 01, 2002 1:04 am


Return to Realtime and Embedded

Who is online

Users browsing this forum: No registered users and 2 guests