Skip navigation.
Home
The QNX Community Portal

View topic - Build Qt5 on qnx 6.4.1

Page 1 of 1

Build Qt5 on qnx 6.4.1

PostPosted: Thu Dec 27, 2012 7:24 am
by madalff
Is qnx 6.4.1 supported by Qt5? I’m trying to build it and getting the following error on ./configure

The specified system/compiler is not supported:
qtbase/mkspecs/unsupported/qnx-q++

Re: Build Qt5 on qnx 6.4.1

PostPosted: Thu Dec 27, 2012 2:15 pm
by maschoen
My recollection of trying to get Qt to compile about 6 months ago, dim as it is, was that compiling on a self hosted QNX system was not supported. Instead I was told that I should compile Qt on a Linux cross-compilation system.

This fits the direction that QNX seems to be going, which is to not support a serious self hosted development environment, by eliminating Photon.

Here's a link if you want to seem me rant and rave about this.
http://www.openqnx.com/phpbbforum/viewt ... ted#p52572

Re: Build Qt5 on qnx 6.4.1

PostPosted: Thu Jan 03, 2013 2:10 pm
by Thunderblade
maschoen wrote:My recollection of trying to get Qt to compile about 6 months ago, dim as it is, was that compiling on a self hosted QNX system was not supported. Instead I was told that I should compile Qt on a Linux cross-compilation system.

This fits the direction that QNX seems to be going, which is to not support a serious self hosted development environment, by eliminating Photon.

Just to be clear: QNX does not directly support Qt on their own. QNX does provide graphics frameworks ("GF", io-display, in 6.4/6.5, and "Screen" in future) onto which Qt can be deployed. Qt in itself is a huge, open source, community driven project that runs on many OSs, including several Embedded OSs from QNX, Green Hills and Wind River. Embedded OSs ussually do NOT provide a capability to run a compiler. So the people behind Qt would never even think about building Qt on QNX. For them, building on Linux is the most normal thing in the world.

The big difference between Qt on QNX and Qt on other Embedded OSs will be (in my opinion) hardware acceleration, provided hopefully by the new "Screen" framework, which also is used by the new BlackBerry 10.

Re: Build Qt5 on qnx 6.4.1

PostPosted: Thu Jan 03, 2013 5:24 pm
by maschoen
I guess I should add that there is now a commercial version of Qt and QNX is supported. If you are interested in the commercial product, you should check out digia.com.

Re: Build Qt5 on qnx 6.4.1

PostPosted: Fri Jan 04, 2013 10:43 am
by Thunderblade
Right. With that being said, QNX and RIM have made significant investments into Qt to enable the Qt community and commercial Qt offerings for QNX Neutrino. To use Qt5, you will need access to the new "Screen" (Core UI) graphics framework, but currently it's only available for customers with priority support contracts AFAIK.