Skip navigation.
Home
The QNX Community Portal

View topic - Embedded Photon on Pxa270

Embedded Photon on Pxa270

Isn't the name clear?

Embedded Photon on Pxa270

Postby jiangxh2222 » Mon Jul 23, 2007 9:15 am

I am building an embedded photon app but I am having trouble with photon loading correctly.
I am running v6.3, on PXA270.
All runs ok - Disk, Network, serial port etc, but I cannot get photon to start
This is the output of sloginfo.

Download complete, calling image_scan...
Found image, calling image_setup...
image_setup complete, calling image_start...
Dcache: 1024x32 WB
Icache: 1024x32
pxa270 rev 4 208MHz

System page at phys:a0014000 user:fc404000 kern:fc404000
Starting next program at vfe0203a4
Welcome to QNX Neutrino 6.3 on the Intel DBPXA270 Development Platform
Starting Photon server...
Starting graphics driver...
# Fatal error - check sloginfo.

# sloginfo
Time Sev Major Minor Args
Jan 01 00:00:00 1 8 0 phfont_init
Jan 01 00:00:00 1 8 0 phfontXX started OK
Jan 01 00:00:00 1 8 0 FatalError
Jan 01 00:00:00 1 8 0 font directory error - unable to open directory file io-font
Jan 01 00:00:00 1 8 0 Unable to launch Photon Font Server main.
Jan 01 00:00:00 2 8 0 Unable to open font DLL

Any ideas?
What's missing?
jiangxh2222
New Member
 
Posts: 2
Joined: Mon Jul 23, 2007 9:09 am

RE: Embedded Photon on Pxa270

Postby micro » Mon Jul 23, 2007 12:12 pm

guess io-font
No Font Server is starting
micro
Senior Member
 
Posts: 458
Joined: Thu Jul 22, 2004 8:41 pm

RE: Embedded Photon on Pxa270

Postby micro » Mon Jul 23, 2007 2:23 pm

fds:
/usr/photon/bin/phfont
/usr/photon/bin/fontsleuth

/lib/libfont.so.1
/lib/dll/phfont.so
/lib/libfontharnessutils.so.1
/lib/dll/font/FCore.so
...


phfont:
/dev/con1
/dev/slog
/usr/photon/font_repository/tt2001m_.ttf
/usr/photon/font_repository/tt2003m_.ttf
/usr/photon/font_repository/tt2009m_.ttf
/dev/phfont
/dev/phfont32
/dev/phfont64

fontsleuth:
/dev/phfont
/usr/photon/font_repository
/dev/fontsleuthctrl

These are used by Photon(and apps) on my system.
micro
Senior Member
 
Posts: 458
Joined: Thu Jul 22, 2004 8:41 pm

RE: Embedded Photon on Pxa270

Postby bedmond » Tue Jul 24, 2007 6:13 pm

How do you start Photon? Are you using phfont directly or letting io-graphics start it? If you let io-graphics start it you need /lib/dll/phfont.so and /lib/dll must be in your CS_LIBPATH. Post your startup script if you like.

Brian
bedmond
Active Member
 
Posts: 19
Joined: Tue Apr 17, 2007 2:13 am

RE: Embedded Photon on Pxa270

Postby jiangxh2222 » Fri Jul 27, 2007 6:51 am

when I start pterm.
#
# pterm /proc/boot/ksh &
[1] 65546
# unknown symbol: PtWindowToFront
unknown symbol: PtWindowGetFrameSize
Could not resolve all symbols

why?
jiangxh2222
New Member
 
Posts: 2
Joined: Mon Jul 23, 2007 9:09 am


Return to GUI Programming

Who is online

Users browsing this forum: No registered users and 1 guest