Skip navigation.
Home
The QNX Community Portal

View topic - debug by serial port

debug by serial port

Read-only archive of qnx.newuser (Installation, configuration and administration of the QNX Neutrino or QNX Momentics environments) at inn.qnx.com

debug by serial port

Postby jalonso » Wed Jan 24, 2007 11:10 am

Hello,

I´m trying to debug by serial port in a target machine (with Eclipse)
but I can´t. A timeout error occurs.

I have done the next steps. First, I have joined with a null modem cable
(the cable is like QNX Help says) the serial port 1 of my computer with
serial port 1 of my target. Second, I have started the serial driver in
target machine (different ways), the pseudo-terminal communications
manager, and the debug agent.

devc-ser8250 -e -b115200 3f8,4 -b9600 2f8,3 &
devc-pty &
pdebug dev/ser1,115200 &

Next, I have launched the debug program by Eclipse (I have configured
Eclipse for debugging by serial port 1 at 115200). Finally, the timeout
error happens.

I think the communication between my computer and the target fail, but I
don´t know why. Does someone know if I do anything wrong?

Can someone help me, please?

Thanks in advance,

Jorge.
jalonso
Active Member
 
Posts: 20
Joined: Tue Mar 07, 2006 4:27 pm

Re: debug by serial port

Postby Mario Charest » Thu Jan 25, 2007 6:05 am

"Jorge" <jalonso@ain.es> wrote in message news:ep7emb$id2$1@inn.qnx.com...
Hello,

I´m trying to debug by serial port in a target machine (with Eclipse) but
I can´t. A timeout error occurs.

I have done the next steps. First, I have joined with a null modem cable
(the cable is like QNX Help says) the serial port 1 of my computer with
serial port 1 of my target. Second, I have started the serial driver in
target machine (different ways), the pseudo-terminal communications
manager, and the debug agent.

devc-ser8250 -e -b115200 3f8,4 -b9600 2f8,3 &
devc-pty &
pdebug dev/ser1,115200 &

Next, I have launched the debug program by Eclipse (I have configured
Eclipse for debugging by serial port 1 at 115200). Finally, the timeout
error happens.

I think the communication between my computer and the target fail, but I
don´t know why. Does someone know if I do anything wrong?

LOTS of thing can be going wrong. Dead serial port (on either machine),
misconfiguration software and hardware, bad cable, etc.

Try to use simple shell command like cat <filenameofchoice> </dev/ser1

Then under Windows use something like hyperterminal to see if you are
getting something.

Can someone help me, please?

Thanks in advance,

Jorge.
Mario Charest
 


Return to qnx.newuser

Who is online

Users browsing this forum: No registered users and 2 guests