Skip navigation.
Home
The QNX Community Portal

View topic - Settings on a Ethernet NIC

Settings on a Ethernet NIC

Read-only archive of qnx.newuser (Installation, configuration and administration of the QNX Neutrino or QNX Momentics environments) at inn.qnx.com

Settings on a Ethernet NIC

Postby dadji » Wed May 30, 2007 8:51 am

hallo,
does somebody know how to set the transfer mode (half or full duplex) and
the data transfer speed (10, 100 MB/s) for an ethernet Network Interface
card.
Thanks
Yannick D.
dadji
 

re:Settings on a Ethernet NIC

Postby ajikumarmp » Wed May 30, 2007 10:18 am

Hi Yannick,

You need to set it while loading the driver, that is there is a ".so" driver that you will be loading along with io-net option. look for the different option of the driver and you will get it.

someone correct me if i am wrong!!
ajikumarmp
Active Member
 
Posts: 14
Joined: Mon Dec 11, 2006 11:22 am

Re: re:Settings on a Ethernet NIC

Postby dadji » Thu May 31, 2007 8:16 am

thanks,
i try it.
best regards.
Yannick
"ajikumarmp" <aji.mp@ge-dot-com.no-spam.invalid> schrieb im Newsbeitrag
news:f3johv$u1$1@inn.qnx.com...
Hi Yannick,

You need to set it while loading the driver, that is there is a
".so" driver that you will be loading along with io-net
option. look for the different option of the driver and you will get
it.

someone correct me if i am wrong!!
dadji
 

Re: re:Settings on a Ethernet NIC

Postby dadji » Fri Jun 01, 2007 8:44 am

hallo,
i tried to re-load the driver with the corresponding options in the shell,
but i didn't succeed. I gabe the following command in der shell:
"io-net -d rtl duplex=1, speed=100, priority=100". I received the following
error:
"unable to init dll devn-rtl: no such device".

My questions:
- what did i do wrong?
- Is there a special qnx-file where i can do the setting to load the
driver with the corresponding options.?
Thanks in advance
Yannick D.
"unable to init dl devn-rtl: no such device"

"io-net -d rtl duplex=1,speed=100, pririty=100"

"ajikumarmp" <aji.mp@ge-dot-com.no-spam.invalid> schrieb im Newsbeitrag
news:f3johv$u1$1@inn.qnx.com...
Hi Yannick,

You need to set it while loading the driver, that is there is a
".so" driver that you will be loading along with io-net
option. look for the different option of the driver and you will get
it.

someone correct me if i am wrong!!
dadji
 

Re: re:Settings on a Ethernet NIC

Postby seanb » Fri Jun 01, 2007 3:26 pm

dadji <ydadji@hotmail.com> wrote:
hallo,
i tried to re-load the driver with the corresponding options in the shell,
but i didn't succeed. I gabe the following command in der shell:
"io-net -d rtl duplex=1, speed=100, priority=100". I received the following
error:
"unable to init dll devn-rtl: no such device".

My questions:
- what did i do wrong?
- Is there a special qnx-file where i can do the setting to load the
driver with the corresponding options.?
Thanks in advance
Yannick D.
"unable to init dl devn-rtl: no such device"

"io-net -d rtl duplex=1,speed=100, pririty=100"

Not sure it this is your issue but you can't have
spaces after the ','.

-seanb
seanb
QNX Master
 
Posts: 133
Joined: Fri Jul 28, 2006 5:36 pm

re:Settings on a Ethernet NIC

Postby ajikumarmp » Sun Jun 03, 2007 5:39 pm

Hi,

in case removing space doesnt make any difference...

Ensure you do the following
1. Slay all the instances of io-net
2. Check the library path whether it includes the path where the driver(.so) for rtl - devn-rtl.so is present.
3. if not set path
4. Reload the io-net again and check nicinfo
ajikumarmp
Active Member
 
Posts: 14
Joined: Mon Dec 11, 2006 11:22 am


Return to qnx.newuser

Who is online

Users browsing this forum: No registered users and 1 guest