Skip navigation.
Home
The QNX Community Portal

View topic - Help!! simple bootable cd problem

Help!! simple bootable cd problem

Read-only archive of qnx.rtos (Writing resources managers, and general discussion around the QNX Neutrino RTOS) at inn.qnx.com

Help!! simple bootable cd problem

Postby ranzhang » Fri Sep 21, 2007 2:16 pm

I burned a CD using the build file below, it is bootable, but for some reason, the directory (/fs) I put on the CD in addition to the image file isn't displayed when i boot on the Cd, all i can see are /dev, /usr, i dont see /fs, if i view this CD on window machine, i see the image file along with /fs, what's going on??

[virtual="x86,bios +compress"] .bootstrap = {
startup-bios
PATH=/proc/boot procnto
}
[+script] .script = {
devc-con -e &
devb-eide &
reopen /dev/con1
[+session] PATH=/proc/boot esh
}
libc.so
libcam.so
cam-disk.so
io-blk.so
fs-qnx4.so

[data=copy]
devc-con
esh
ls
devb-eide
[type=link] /usr/lib/ldqnx.so.2=/proc/boot/libc.so.2
fdisk
mount
dinit
ranzhang
Active Member
 
Posts: 35
Joined: Tue Nov 14, 2006 3:33 pm

RE: Help!! simple bootable cd problem

Postby maschoen » Fri Sep 21, 2007 5:02 pm

This is just a guess, but if you use the QNX hosted version, you will see that /fs has links to disks other than your boot disk. I don't know how it gets there, but possibly proc creates it. So there may be a namespace override that's hiding your CD /fs directory. If this is the case, there probably is a way to turn it off, or change it.
maschoen
QNX Master
 
Posts: 2640
Joined: Wed Jun 25, 2003 5:18 pm


Return to qnx.rtos

Who is online

Users browsing this forum: No registered users and 1 guest

cron