Skip navigation.
Home
The QNX Community Portal

View topic - sigaction error

sigaction error

Read-only archive of qnx.rtos (Writing resources managers, and general discussion around the QNX Neutrino RTOS) at inn.qnx.com

sigaction error

Postby dadji » Fri Dec 21, 2007 4:52 pm

Hello,
can it be that the sigaction() funtion for signal handling is not supported
on qnx6.3.2. This function returns an error. strerror(errno) return "Not
supported". However the same code works on another system with qnx6.3.0,
SP2.
merry Christmas
Yannick
dadji
 

Re: sigaction error

Postby David Gibbs » Fri Dec 21, 2007 6:14 pm

dadji <ydadji@hotmail.com> wrote:
Hello,
can it be that the sigaction() funtion for signal handling is not supported
on qnx6.3.2. This function returns an error. strerror(errno) return "Not
supported". However the same code works on another system with qnx6.3.0,
SP2.

There is no intention or expectation that sigaction() will stop working with
6.3.2, and I have used it.

Can you post your call (with all the setup structures) that has stopped
working?

Is it possible you've not initialized one of the structures passed
in, and that you were lucky to get "safe" values in an earlier compile, but
not with a more recent build?

-David

merry Christmas
Yannick



--
David Gibbs
QNX Training Services
dagibbs@qnx.com
David Gibbs
 

RE: sigaction error

Postby maschoen » Fri Dec 21, 2007 7:21 pm

I'm not at my system to test this right now, but I would imagine a lot of things would break if this were the case. 6.3.2 has been out long enough that this is unlikely. Maybe it is something more circumstantial, a bad signal number or perhaps trying to use a signal which requires super user privileges when they are not available?

Maybe post your sigaction code?
maschoen
QNX Master
 
Posts: 2644
Joined: Wed Jun 25, 2003 5:18 pm

Re: sigaction error

Postby dadji » Wed Jan 02, 2008 10:42 am

hello David,
thanks for the support. the file contains the piece of code with the
sigaction call.

Yannick

"David Gibbs" <dagibbs@qnx.com> schrieb im Newsbeitrag
news:fkgvpq$quh$1@inn.qnx.com...
dadji <ydadji@hotmail.com> wrote:
Hello,
can it be that the sigaction() funtion for signal handling is not
supported
on qnx6.3.2. This function returns an error. strerror(errno) return "Not
supported". However the same code works on another system with qnx6.3.0,
SP2.

There is no intention or expectation that sigaction() will stop working
with
6.3.2, and I have used it.

Can you post your call (with all the setup structures) that has stopped
working?

Is it possible you've not initialized one of the structures passed
in, and that you were lucky to get "safe" values in an earlier compile,
but
not with a more recent build?

-David

merry Christmas
Yannick



--
David Gibbs
QNX Training Services
dagibbs@qnx.com


begin 666 NewsGrouptext.txt
M<W1A=&EC('9O:60@245%13$S.313:6=L2&%N9&QE<B@@:6YT(&E3:6=N86P@
M*0T*>PT*"7!R:6YT9B@B245%13$S.313:6=L2&%N9&QE<B!A8W1I=F5<;B(I
M.PT*"7-W:71C:"@@:5-I9VYA;" I#0H)>PT*"0EC87-E(%-)1TE.5#H-"@D)
M"0D)"6EF*'5I57-E<E-T871U<R ]/2!35$%455-?15A)5"D-"@D)"0D)"7L-
M"@D)"0D)"0DO+R!S:'5T9&]W;B!T:&4@9')I=F5R#0H)"0D)"0D)#0H)"0D)
M"0D)+R\@9&5S=')O>2!C:&%N;F5L#0H)"0D)"0D)0VAA;FYE;$1E<W1R;WDH
M3VAC:4-A<F0N:6-H:60I.PT*"0D)"0D)"0T*"0D)"0D)"2\O($1I<V-O;FYE
M8W1I;VX@;V8@=&AE(&-A<F0@9G)O;2!T:&4@4$-)+5-E<G9E<B F(&UE;6]R
M>2!R96QE87-E( T*"0D)"0D)"4E%144Q,SDT7TA77U!#25]296UO=F4H)D]H
M8VE#87)D*3L-"@D)"0D)"7T-"@D)"0D)"0T*"0D)"0D)8G)E86L[#0H-"@D)
M9&5F875L=#H)"6)R96%K.PT*#0H)?0T*?0T*#0H-"FEN="!M86EN*&EN="!I
M87)G8RP@8VAA<B J<&-A<F=V6UTI#0I[#0H)=6YS:6=N960@:6YT"0EU:45R
M<F]R.PT*+R\)=$=L;V)A;%]#;VYF:6<@3VAC:4-A<F0[#0H)<W1R=6-T('-I
M9V%C=&EO;@ES06-T.PD)"0DO+R!S:6=N86P@86-T:6]N('-T<G5C='5R92!T
M;R!H86YD;&4@:6YC;VUI;F<@<VEG;F%L<PT*"0T*"7-!8W0N<V%?:&%N9&QE
M<@D]($E%144Q,SDT4VEG;$AA;F1L97([#0H):68@*"!S:6=A8W1I;VXH(%-)
M1TE.5"P@)G-!8W0L($Y53$P@*2 A/2 P*2 -"@D)<')I;G1F*")L;V%D:6YG
M('-I9VYA;"!H86YD;&5R(&9A:6QE9"P@17)R;ULE9%T@;65A:6YI;F=;)7-=
K7&XB+"!E<G)N;RP@<W1R97)R;W(H97)R;F\I*3L-"@DN+BX-"@T*?0T*"0``
`
end
dadji
 

Re: sigaction error

Postby dadji » Wed Jan 02, 2008 1:53 pm

Hello,
i found the error. it didn't set thte sigaction structure element "sa_flags"
to 0. the default value was 0xffffffff.
Now that i set it to 0, every thing is functioning very well.

Thanks for your help.
Yannick

"David Gibbs" <dagibbs@qnx.com> schrieb im Newsbeitrag
news:fkgvpq$quh$1@inn.qnx.com...
dadji <ydadji@hotmail.com> wrote:
Hello,
can it be that the sigaction() funtion for signal handling is not
supported
on qnx6.3.2. This function returns an error. strerror(errno) return "Not
supported". However the same code works on another system with qnx6.3.0,
SP2.

There is no intention or expectation that sigaction() will stop working
with
6.3.2, and I have used it.

Can you post your call (with all the setup structures) that has stopped
working?

Is it possible you've not initialized one of the structures passed
in, and that you were lucky to get "safe" values in an earlier compile,
but
not with a more recent build?

-David

merry Christmas
Yannick



--
David Gibbs
QNX Training Services
dagibbs@qnx.com
dadji
 

Re: sigaction error

Postby David Gibbs » Wed Jan 02, 2008 8:20 pm

dadji <ydadji@hotmail.com> wrote:
Hello,
i found the error. it didn't set thte sigaction structure element "sa_flags"
to 0. the default value was 0xffffffff.
Now that i set it to 0, every thing is functioning very well.

Good.

Thanks for your help.

You're welcome.

-David

Is it possible you've not initialized one of the structures passed
in, and that you were lucky to get "safe" values in an earlier compile,
but
not with a more recent build?

--
David Gibbs
QNX Training Services
dagibbs@qnx.com
David Gibbs
 


Return to qnx.rtos

Who is online

Users browsing this forum: No registered users and 1 guest

cron