Skip navigation.
Home
The QNX Community Portal

View topic - Strange bug while unloading devi-hid input manager

Strange bug while unloading devi-hid input manager

Read-only archive of qnx.rtos (Writing resources managers, and general discussion around the QNX Neutrino RTOS) at inn.qnx.com

Strange bug while unloading devi-hid input manager

Postby Mike Gorchak » Tue Jan 15, 2008 7:15 am

Hello, All!

I need to use mouse and also full keyboard (usb and ps/2) in the console,
without Photon. For this purpouse I am starting devi-hid input manager like
this "/usr/photon/bin/devi-hid -Pr mouse kbd" . I'm spawning process
devi-hid from the my application when it needs keyboard and mouse support
(this is dynamically loaded application, also spawn by other application).
So I need to run and slay devi-hid input manager appr. 10 or 20 times per
day.

Here we go. After few devi-hid process starts/slays devi-hid hangs during
start.

Try to run the following simplified script few times to reproduce the
problem (2-5 times to run to reproduce hangings):

Is it known problem ? If not, are there ways to avoid hangings ?

#--------------------------------------------------------------
#!/bin/sh
echo "devi-hid start"
/usr/photon/bin/devi-hid -Pr mouse kbd
echo "slay devi-hid"
slay devi-hid
echo "devi-hid start"
/usr/photon/bin/devi-hid -Pr mouse kbd
echo "slay devi-hid"
slay devi-hid
echo "devi-hid start"
/usr/photon/bin/devi-hid -Pr mouse kbd
echo "slay devi-hid"
slay devi-hid
echo "devi-hid start"
/usr/photon/bin/devi-hid -Pr mouse kbd
echo "slay devi-hid"
slay devi-hid

#--------------------------------------------------------------

Thanks in advance !

With best regards, Mike Gorchak. E-mail: mike@malva.ua
Mike Gorchak
 

Return to qnx.rtos

Who is online

Users browsing this forum: No registered users and 1 guest