Skip navigation.
Home
The QNX Community Portal

View topic - Momentics 6.3.0SP2 & CVS extssh error

Momentics 6.3.0SP2 & CVS extssh error

Read-only archive of qnx.development_tools (Self-hosted graphical development with the Eclipse IDE and cross-hosted development on Solaris, Linux, or Windows) at inn.qnx.com

Momentics 6.3.0SP2 & CVS extssh error

Postby Dan Sperka » Wed Jul 12, 2006 10:45 pm

I'm using Momentics 6.3.0SP2 under Neutrino 6.3.0. When accessing a CVS
repository on a remote machine using "extssh" I get errors from eclipse
which read "Error validating location: javax/crypto/KeyAgreement". (My
CVS repository requires extssh access - no pserver access allowed.)

This error seems to have been solved with Eclipse 3.1 (Momentics
6.3.0SP2 is based on Eclipse 3.0).

Can I upgrade eclipse to 3.1 and have the Momentics plugin still work?

If I can upgrade eclipse, how do I go about doing it (EClipse's
Help>Software Updates>Updates doesn't return any updates for currently
installed features, like the Eclipse platform).

Thanks,

Dan
Dan Sperka
 

Re: Momentics 6.3.0SP2 & CVS extssh error

Postby ntallen » Fri Dec 08, 2006 3:46 pm

I am encountering this same problem. Is there any workaround? It all
works fine under Windows, but I'd like to be able to develop on Neutrino
as well. Can we beta the Eclipse 3.1 for Neutrino?
-Norton Allen

Dan Sperka wrote:
I'm using Momentics 6.3.0SP2 under Neutrino 6.3.0. When accessing a CVS
repository on a remote machine using "extssh" I get errors from eclipse
which read "Error validating location: javax/crypto/KeyAgreement". (My
CVS repository requires extssh access - no pserver access allowed.)

This error seems to have been solved with Eclipse 3.1 (Momentics
6.3.0SP2 is based on Eclipse 3.0).

Can I upgrade eclipse to 3.1 and have the Momentics plugin still work?

If I can upgrade eclipse, how do I go about doing it (EClipse's
Help>Software Updates>Updates doesn't return any updates for currently
installed features, like the Eclipse platform).

Thanks,

Dan
ntallen
New Member
 
Posts: 3
Joined: Tue Apr 12, 2005 2:02 am
Location: Cambridge, MA

Re: Momentics 6.3.0SP2 & CVS extssh error

Postby ntallen » Fri Dec 08, 2006 4:27 pm

Hmmm, actually all the Eclipse version information is the same for my
Neutrino installation and my Windows installation, but I only get the
javax/crypto/KeyAgreement error under Neutrino. Is the problem in the
underlying Java VM? I show 1.4.2 under Windows and 1.4.1 under Neutrino.
-Norton

Norton Allen wrote:
I am encountering this same problem. Is there any workaround? It all
works fine under Windows, but I'd like to be able to develop on Neutrino
as well. Can we beta the Eclipse 3.1 for Neutrino?
-Norton Allen

Dan Sperka wrote:

I'm using Momentics 6.3.0SP2 under Neutrino 6.3.0. When accessing a
CVS repository on a remote machine using "extssh" I get errors from
eclipse which read "Error validating location:
javax/crypto/KeyAgreement". (My CVS repository requires extssh access
- no pserver access allowed.)

This error seems to have been solved with Eclipse 3.1 (Momentics
6.3.0SP2 is based on Eclipse 3.0).

Can I upgrade eclipse to 3.1 and have the Momentics plugin still work?

If I can upgrade eclipse, how do I go about doing it (EClipse's
Help>Software Updates>Updates doesn't return any updates for currently
installed features, like the Eclipse platform).

Thanks,

Dan
ntallen
New Member
 
Posts: 3
Joined: Tue Apr 12, 2005 2:02 am
Location: Cambridge, MA

Re: Momentics 6.3.0SP2 & CVS extssh error

Postby Mario Charest » Fri Dec 08, 2006 8:28 pm

"Norton Allen" <allen@huarp.harvard.edu> wrote in message
news:45799259.10309@huarp.harvard.edu...
Hmmm, actually all the Eclipse version information is the same for my
Neutrino installation and my Windows installation, but I only get the
javax/crypto/KeyAgreement error under Neutrino. Is the problem in the
underlying Java VM? I show 1.4.2 under Windows and 1.4.1 under Neutrino.
-Norton


To my knowledge Eclipse 3.1 doesn't work under Neutrino. Some feature
missing from the JVM I think.

Personally have working with CDT 3.1 (and beta 4.0) I wouldn't touch version
2 with a 10 feet pole.


Norton Allen wrote:
I am encountering this same problem. Is there any workaround? It all
works fine under Windows, but I'd like to be able to develop on Neutrino
as well. Can we beta the Eclipse 3.1 for Neutrino?
-Norton Allen

Dan Sperka wrote:

I'm using Momentics 6.3.0SP2 under Neutrino 6.3.0. When accessing a CVS
repository on a remote machine using "extssh" I get errors from eclipse
which read "Error validating location: javax/crypto/KeyAgreement". (My
CVS repository requires extssh access - no pserver access allowed.)

This error seems to have been solved with Eclipse 3.1 (Momentics
6.3.0SP2 is based on Eclipse 3.0).

Can I upgrade eclipse to 3.1 and have the Momentics plugin still work?

If I can upgrade eclipse, how do I go about doing it (EClipse's
Help>Software Updates>Updates doesn't return any updates for currently
installed features, like the Eclipse platform).

Thanks,

Dan
Mario Charest
 


Return to qnx.development_tools

Who is online

Users browsing this forum: No registered users and 2 guests