Skip navigation.
Home
The QNX Community Portal

View topic - Strange IDE4 CVS extssh connection behavior

Strange IDE4 CVS extssh connection behavior

Read-only archive of qnx.development_tools (Self-hosted graphical development with the Eclipse IDE and cross-hosted development on Solaris, Linux, or Windows) at inn.qnx.com

Strange IDE4 CVS extssh connection behavior

Postby kwschumm » Thu Aug 23, 2007 5:48 pm

We have three developers using Windows XP hosted Momentics 4.0.1 in a
distributed development effort. Each developer is at a different location
and all connect to a remote CVS server located at a fourth location.

All developers simultaneously started having problems with Momentics CVS
connections failing due to timeouts. We do not know exactly what event
precipitated the problem.

There seemed to be nothing wrong with the CVS server. We rebooted the router
and server and it didn't solve the problem. Connecting a laptop on the
servers LAN allowed CVS access into the server without problems. All
developers could remotely SSH and login to the server using putty but any
remote CVS connection from Momentics would timeout.

The only thing that got us going again was stopping and restarting Momentics
on each Developer machine. We did not have to reboot the development
machines.

It's almost like Momentics remembered that a failure occurred and refused to
try again until it was restarted.
kwschumm
Senior Member
 
Posts: 306
Joined: Fri Sep 17, 2004 12:46 pm

Return to qnx.development_tools

Who is online

Users browsing this forum: No registered users and 2 guests