Skip navigation.
Home
The QNX Community Portal

View topic - Total5200 BSP ver 1.0 - problems while building

Total5200 BSP ver 1.0 - problems while building

Read-only archive of qnx.bsp (Discuss building an image, flashing a board or using a BSP) at inn.qnx.com

Total5200 BSP ver 1.0 - problems while building

Postby ramyssysix » Wed Oct 26, 2005 6:11 pm

Hello,

I just downloaded the version 1.0 source BSP for Total5200 (Windows Host) from QNX web site. I am using QNX Momentics IDE with Service Pack 1. I am getting the following errors while building.

Does anybody have any idea why I am getting these errors?

Does anybody have experience building that source BSP before? Did it work without errors?

Also, can I generate a minimal ifs image out of this that is ready for downloading into the Total5200 board?

===============================================

Kind Status Priority Description Resource In Folder Location
Error *** [C:/QNX630/workspace/bsp-mgt5200_devc-serpsc/serpsc/ppc/o.be/devc-serpsc] Error 1 bsp-mgt5200_devc-serpsc

Error icpower.o */QNX630/target/qnx6/ppcbe/usr/lib/libio-char.a(icpower.o): In function `iochar_regdrv_power': undefined reference to `drv_ps_obj_id_from_addr64' bsp-mgt5200_devc-serpsc line 0

Error icpower.o * undefined reference to `drv_ps_obj_id_from_addr64' relocation truncated to fit: R_PPC_REL24 drv_ps_obj_id_from_addr64 bsp-mgt5200_devc-serpsc line 0

Error pstore.o */QNX630/target/qnx6/ppcbe/usr/lib/libio-char.a(pstore.o): In function `pstore_delete': undefined reference to `ps_obj_close' bsp-mgt5200_devc-serpsc line 0

Error pstore.o */QNX630/target/qnx6/ppcbe/usr/lib/libio-char.a(pstore.o): In function `pstore_open': undefined reference to `ps_obj_open' bsp-mgt5200_devc-serpsc line 0

Error pstore.o */QNX630/target/qnx6/ppcbe/usr/lib/libio-char.a(pstore.o): In function `pstore_restore_state': undefined reference to `ps_obj_loadable' bsp-mgt5200_devc-serpsc line 0

Error pstore.o */QNX630/target/qnx6/ppcbe/usr/lib/libio-char.a(pstore.o): In function `pstore_save_state': undefined reference to `ps_obj_store' bsp-mgt5200_devc-serpsc line 0

Error pstore.o * relocation truncated to fit: R_PPC_REL24 ps_obj_close undefined reference to `ps_obj_unlink' bsp-mgt5200_devc-serpsc line 0

Error pstore.o * relocation truncated to fit: R_PPC_REL24 ps_obj_loadable undefined reference to `ps_obj_load' bsp-mgt5200_devc-serpsc line 0

Error pstore.o * relocation truncated to fit: R_PPC_REL24 ps_obj_load undefined reference to `ps_obj_loadable' bsp-mgt5200_devc-serpsc line 0

Error pstore.o * relocation truncated to fit: R_PPC_REL24 ps_obj_store undefined reference to `ps_obj_store' bsp-mgt5200_devc-serpsc line 0

Error pstore.o * undefined reference to `ps_obj_close' relocation truncated to fit: R_PPC_REL24 ps_obj_close bsp-mgt5200_devc-serpsc line 0

Error pstore.o * undefined reference to `ps_obj_load' relocation truncated to fit: R_PPC_REL24 ps_obj_load bsp-mgt5200_devc-serpsc line 0

Error pstore.o * undefined reference to `ps_obj_loadable' relocation truncated to fit: R_PPC_REL24 ps_obj_loadable bsp-mgt5200_devc-serpsc line 0

Error pstore.o * undefined reference to `ps_obj_open' relocation truncated to fit: R_PPC_REL24 ps_obj_open bsp-mgt5200_devc-serpsc line 0

Error pstore.o * undefined reference to `ps_obj_store' relocation truncated to fit: R_PPC_REL24 ps_obj_store bsp-mgt5200_devc-serpsc line 0

Error tore.o * Leaving directory `C:/QNX630/workspace/bsp-mgt5200_devc-serpsc/serpsc' relocation truncated to fit: R_PPC_REL24 ps_obj_unlink bsp-mgt5200_devc-serpsc line 0

Warning `timer_init' declared `static' but never defined touch.c bsp-mgt5200_devi-mpc5200/mpc5200 line 83

Warning (near initialization for `hparm._reserved') hid.c bsp-mgt5200_input line 190

Warning missing braces around initializer hid.c bsp-mgt5200_input line 190

Warning unused variable `down' keyboard.c bsp-mgt5200_input line 235
ramyssysix
Active Member
 
Posts: 10
Joined: Wed Oct 26, 2005 6:03 pm

re:Total5200 BSP ver 1.0 - problems while building

Postby ramyssysix » Wed Oct 26, 2005 7:27 pm

Turned out that I had to use the version 1.0.2 BSP given the QNX Momentics IDE 3.0 and SP1.

Thanks anyways.
ramyssysix
Active Member
 
Posts: 10
Joined: Wed Oct 26, 2005 6:03 pm

Re: Total5200 BSP ver 1.0 - problems while building

Postby David Gibbs » Wed Oct 26, 2005 9:09 pm

ramyssysix <wsaleem@fma.fujitsu-dot-com.no-spam.invalid> wrote:
Hello,

I just downloaded the version 1.0 source BSP for Total5200 (Windows
Host) from QNX web site. I am using QNX Momentics IDE with Service
Pack 1. I am getting the following errors while building.

Does anybody have any idea why I am getting these errors?

SP1 added support for power-management into the character devices
(serial port driver), and these are failures building that device.

Possible steps:
- check to see if there is an updated SP1 BSP for this board.
- search the QNX site for instructions on modifying a 6.3.0 BSP
for SP1. I'm pretty sure it has been described somewhere, but
I'm not sure where.

Does anybody have experience building that source BSP before? Did it
work without errors?

It would have worked without errors on 6.3.0, but will not work with
6.3.0 SP1. This is a known issue.

Also, can I generate a minimal ifs image out of this that is ready for
downloading into the Total5200 board?

Don't know.

-David
--
David Gibbs
QNX Training Services
dagibbs@qnx.com
David Gibbs
 

re:Total5200 BSP ver 1.0 - problems while building

Postby massoud » Sun Apr 29, 2007 2:40 pm

Hi,
I have had such problem, I found a library named libps.a in my QNX installation path, D:\QNX630\target\qnx6\ppcbe\usr\lib , after adding it, the problem was solved successfully.
try it.
massoud
New Member
 
Posts: 1
Joined: Sun Apr 29, 2007 2:34 pm


Return to qnx.bsp

Who is online

Users browsing this forum: No registered users and 1 guest

cron