Skip navigation.
Home
The QNX Community Portal

View topic - XML LIB

XML LIB

Read-only archive of qnx.qnx4 (General QNX4 Discussion Group) at inn.qnx.com

XML LIB

Postby Augie » Tue Jul 11, 2006 3:22 pm

Hi All.

Are there any XML 1.0 support functions for QNX 4?

TIA

Augie
Augie
 

Re: XML LIB

Postby Robert Rutherford » Thu Jul 13, 2006 11:49 am

On 2006-07-12 01:22:14 +1000, "Augie" <augiehenriques@hotmail.com> said:

Hi All.

Are there any XML 1.0 support functions for QNX 4?


We use libxml2 (www.xmlsoft.org)

Rob Rutherford
Ruzz Technology
Robert Rutherford
 

Re: XML LIB

Postby Augie » Thu Jul 13, 2006 1:14 pm

Rob,

Thanks. I found libxml2, but I had trouble installing.

I ran ./configure and a got an error...

configure: error: no acceptable ld found in $PATH.

Did you get this error?

I set a symbolic link for ld to wlib and still I get the problem.

TIA

Augie

"Robert Rutherford" <ruzz@NoSpamPlease.ruzz.com> wrote in message
news:2006071321490416807-ruzz@NoSpamPleaseruzzcom...
On 2006-07-12 01:22:14 +1000, "Augie" <augiehenriques@hotmail.com> said:

Hi All.

Are there any XML 1.0 support functions for QNX 4?


We use libxml2 (www.xmlsoft.org)

Rob Rutherford
Ruzz Technology
Augie
 

Re: XML LIB

Postby Robert Rutherford » Mon Jul 17, 2006 4:04 am

On 2006-07-13 23:14:41 +1000, "Augie" <augiehenriques@hotmail.com> said:

Rob,

Thanks. I found libxml2, but I had trouble installing.

I ran ./configure and a got an error...

configure: error: no acceptable ld found in $PATH.


We use version 2.6.14 which is from September 2004. We have had no need
to update (but we are not exactly heavy users of the lib).

It builds OK for us with the following configure command:

$ CC=cc CXX=CC LD=cc CPP="cc -E" CXXCPP="CC -E" CFLAGS="-mf -j -zp4 -5r" \
CXXFLAGS="-mf -j -zp4 -5r" ./configure

Augie I will email you a copy that is built from this.

Rob Rutherford
Ruzz Technology
Robert Rutherford
 

Re: XML LIB

Postby Augie » Fri Jul 21, 2006 3:08 pm

Rob,

Thanks. I got the configure to work.

When I typed 'make' it had nothing to do.

Which Makefile do we use (where is it)?

TIA

Augie

"Robert Rutherford" <ruzz@NoSpamPlease.ruzz.com> wrote in message
news:2006071714040916807-ruzz@NoSpamPleaseruzzcom...
On 2006-07-13 23:14:41 +1000, "Augie" <augiehenriques@hotmail.com> said:

Rob,

Thanks. I found libxml2, but I had trouble installing.

I ran ./configure and a got an error...

configure: error: no acceptable ld found in $PATH.


We use version 2.6.14 which is from September 2004. We have had no need to
update (but we are not exactly heavy users of the lib).

It builds OK for us with the following configure command:

$ CC=cc CXX=CC LD=cc CPP="cc -E" CXXCPP="CC -E" CFLAGS="-mf -j -zp4 -5r" \
CXXFLAGS="-mf -j -zp4 -5r" ./configure

Augie I will email you a copy that is built from this.

Rob Rutherford
Ruzz Technology
Augie
 

Re: XML LIB

Postby booBot » Wed Aug 02, 2006 3:43 pm

On Mon, 17 Jul 2006 08:04:09 +0400, Robert Rutherford
<ruzz@NoSpamPlease.ruzz.com> wrote:
It builds OK for us with the following configure command:

$ CC=cc CXX=CC LD=cc CPP="cc -E" CXXCPP="CC -E" CFLAGS="-mf -j -zp4 -5r"
\
CXXFLAGS="-mf -j -zp4 -5r" ./configure
If I do this for v2.6.26 the "./configure" fails with "error:

C++ preprocessor "CC" fails sanity check" message.

However, if I do just "./configure" - it completes OK.
Then I need to change this:
--- libxml2-2.6.26/xmlwriter.c 2006-04-27 12:09:22.000000000 +0400
+++ libxml2-2.6.26-QNX4/xmlwriter.c 2006-08-02 19:21:40.000000000 +0400
@@ -38,7 +38,11 @@
#ifdef HAVE___VA_COPY
#define VA_COPY(dest,src) __va_copy(dest, src)
#else
+ #ifdef __QNX__
+ #define VA_COPY(dest,src) memcpy(dest, src, sizeof(dest))
+ #else
#define VA_COPY(dest,src) (dest) = (src)
+ #endif
#endif
#endif
#endif

The "make" now goes on and on untill I get the error from my compiler
"Internal limit exceeded, try splitting 'testapi.c' into smaller modules".
Indeed, the 'testapi.c' is over 1.5MB, a biggie one!

What would you suggest?
I'm on Watcom C v10.6B + Security Patch.

Tony.
booBot
Senior Member
 
Posts: 633
Joined: Tue Feb 24, 2004 5:07 pm

Re: XML LIB

Postby booBot » Wed Aug 02, 2006 5:25 pm

On Wed, 02 Aug 2006 19:43:59 +0400, Tony <mts.spb.suxx@mail.ru> wrote:
If I do this for v2.6.26 the "./configure" fails with "error:
C++ preprocessor "CC" fails sanity check" message.
I tryed your environment settings with v2.6.14 - the same "./configure"'s

error message about failng sanity check.

Yet again, running the "./configure" on itself allows to start "make"ing
the library. This one compiles but I'm not shure if it is usable: the
"make check" produces lots of suspicious messages and I see some
"Segmentation fault" in process...

The library (v2.6.14 one) is around 2.9MB.

Please comment.
(And if possible - send me your binaries, please!)

Tony.
booBot
Senior Member
 
Posts: 633
Joined: Tue Feb 24, 2004 5:07 pm

Re: XML LIB

Postby Augie » Fri Aug 11, 2006 7:14 pm

Robert,

I finally gave up and made up my own make file.

I was able to make the lib after changing a few things in some of the files,
specially the config.h

Thank you very much for all your help.

Best Regards,

Augie

"Robert Rutherford" <ruzz@NoSpamPlease.ruzz.com> wrote in message
news:2006071714040916807-ruzz@NoSpamPleaseruzzcom...
On 2006-07-13 23:14:41 +1000, "Augie" <augiehenriques@hotmail.com> said:

Rob,

Thanks. I found libxml2, but I had trouble installing.

I ran ./configure and a got an error...

configure: error: no acceptable ld found in $PATH.


We use version 2.6.14 which is from September 2004. We have had no need to
update (but we are not exactly heavy users of the lib).

It builds OK for us with the following configure command:

$ CC=cc CXX=CC LD=cc CPP="cc -E" CXXCPP="CC -E" CFLAGS="-mf -j -zp4 -5r" \
CXXFLAGS="-mf -j -zp4 -5r" ./configure

Augie I will email you a copy that is built from this.

Rob Rutherford
Ruzz Technology
Augie
 


Return to qnx.qnx4

Who is online

Users browsing this forum: No registered users and 3 guests