Skip navigation.
Home
The QNX Community Portal

View topic - Current configuration of QNX? 4.25

Current configuration of QNX? 4.25

Read-only archive of qnx.qnx4 (General QNX4 Discussion Group) at inn.qnx.com

Current configuration of QNX? 4.25

Postby Darel Cullen » Thu Jul 13, 2006 3:01 pm

Hi,
I am kind of confused as to what the current release of QNX4 is. So many
questions, that I am sure other people wonder about...

What is the latest release of the Proc process and where is it? I see there
is a Proc 4.25Q available on the qnx webpages download center. is this the
latest? Is this not a part of a patchlevel release?

Am I right in thinking that the Patchlevel releases are non cumulative? so
you have to download them all? If so what patchlevels are there between
4.23A and 4.25 latest. What happens if a miss a patchlevel? I saw in the
install notes there is atleast 4.25 A B C D E F G, i can get E and G from
the download center, where can i get all the other patchlevels? Ideally in a
tar file so I can see what is updated.

Is the latest Patch level release G? - Why are only two patchlevels E and G
available via the download center, what happened to F?

What is the most stable version of Watcom.. we have 9.5, but i see there is
a 10.6 beta, was this always beta? is it safe to use?

I don't dare just installing lots of updates over 4.23A as we have a large
application built on it, and how can I be sure that everything will work
after updating to 4.25 latest?

What is the latest (last) supported release of QNXwindows? we have 4.20B,
4.21 and 4.21B but have seen later releases...

What chance is there of regression for an existing application upgrading to
QNX4.25 from 4.23A? Must I upgrade all 16 bit applications to 32bit if
moving to QNX4.25?

What is the role of the product update CDs? we have a few but they seem to
be a mix of different versions..

Do old 4.23A licenses still work with 4.25 in the old format?




I am very grateful for replies to these questions
Darel Cullen
 

Re: Current configuration of QNX? 4.25

Postby booBot » Thu Jul 13, 2006 3:28 pm

On Thu, 13 Jul 2006 19:01:39 +0400, Darel Cullen <nospam-darelj@gmail.com>
wrote:
What is the latest release of the Proc process and where is it? I see
there
is a Proc 4.25Q available on the qnx webpages download center. is this
the
latest?
Yes, it is.


Is this not a part of a patchlevel release?
It is an update.


Am I right in thinking that the Patchlevel releases are non cumulative?
Wrong, it is enough to use the G patch and put all the updates you see on

the download site.

Is the latest Patch level release G?
Yes.


What is the most stable version of Watcom..
Watcom v10.6B + Security fix.


a 10.6 beta, was this always beta? is it safe to use?
Yes, we all use it for years...


Must I upgrade all 16 bit applications to 32bit if moving to QNX4.25?
I do not think so. All the progs I saw kept working OK on 4.25G.


Do old 4.23A licenses still work with 4.25 in the old format?
Yes.

And you may convert the older into the current, I believe.

Tony.
booBot
Senior Member
 
Posts: 633
Joined: Tue Feb 24, 2004 5:07 pm

Re: Current configuration of QNX? 4.25

Postby Darel Cullen » Fri Jul 14, 2006 7:12 am

Thanks for the reply Tony!


"Tony" <mts.spb.suxx@mail.ru> wrote in message
news:op.tcmvxkpmo93ri4@mobile.wst.quantum.ru...
On Thu, 13 Jul 2006 19:01:39 +0400, Darel Cullen <nospam-darelj@gmail.com
wrote:
What is the latest release of the Proc process and where is it? I see
there
is a Proc 4.25Q available on the qnx webpages download center. is this
the
latest?
Yes, it is.

Is this not a part of a patchlevel release?
It is an update.

Am I right in thinking that the Patchlevel releases are non cumulative?
Wrong, it is enough to use the G patch and put all the updates you see on
the download site.

Is the latest Patch level release G?
Yes.

What is the most stable version of Watcom..
Watcom v10.6B + Security fix.

a 10.6 beta, was this always beta? is it safe to use?
Yes, we all use it for years...

Must I upgrade all 16 bit applications to 32bit if moving to QNX4.25?
I do not think so. All the progs I saw kept working OK on 4.25G.

Do old 4.23A licenses still work with 4.25 in the old format?
Yes.
And you may convert the older into the current, I believe.

Tony.
Darel Cullen
 


Return to qnx.qnx4

Who is online

Users browsing this forum: No registered users and 3 guests