Skip navigation.
Home
The QNX Community Portal

View topic - Starting phrelay with options

Starting phrelay with options

Read-only archive of qnx.qnx4 (General QNX4 Discussion Group) at inn.qnx.com

Starting phrelay with options

Postby Oleg Khamayko » Mon Jul 02, 2007 1:16 pm

Hi!

When using phditto how we can force phrelay to start with it's allowed
options?

E.g. if on node 2 we enter command

phditto -n1

and wish that at node 1 the "phrelay" will run with options like

/usr/photon/bin/phrelay -T 10,3

Thanks
Oleg Khamayko
 

Re: Starting phrelay with options

Postby Igor Mazanov » Tue Jul 03, 2007 9:46 am

Oleg,

Why don't you run node1 phrelay in the usual fashion using inetd services
(TCP/IP connection I mean)? You can set phrelay arguments according inetd.conf
file syntax:

# Internet services syntax:
# <service_name> <socket_type> <proto> <flags> <user> <server_pathname> <args>

Regards,
Igor.

Oleg Khamayko wrote:
Hi!

When using phditto how we can force phrelay to start with it's allowed
options?

E.g. if on node 2 we enter command

phditto -n1

and wish that at node 1 the "phrelay" will run with options like

/usr/photon/bin/phrelay -T 10,3

Thanks
Igor Mazanov
 

Re: Starting phrelay with options

Postby Oleg Khamayko » Tue Jul 03, 2007 12:24 pm

Hi, Igor!

I've think about TCP/IP, but we have no TCP/IP stack on that PC's now. Only
FLEET.

I've writen "phrelay" wrapper, which calls phrelay with the parameters, but
it's not a good way...

The problem is that we have "unreliable" radio-ethernet connection between
node 1 and node 2.

When phditto-ing node 1 from node2 and link breaks for some time - phrelay
and phditto disconnects, vc-s remains, phditto and phrelay remains in
memory.

After a week system hangs(((

Maybe not a good decision to use remote access, but we have it.

Igor Mazanov <i.mazanov@swd.ru> wrote in message
news:f6d59b$e1q$1@inn.qnx.com...
Oleg,

Why don't you run node1 phrelay in the usual fashion using inetd services
(TCP/IP connection I mean)? You can set phrelay arguments according
inetd.conf
file syntax:

# Internet services syntax:
# <service_name> <socket_type> <proto> <flags> <user> <server_pathname
args

Regards,
Igor.

Oleg Khamayko wrote:
Hi!

When using phditto how we can force phrelay to start with it's allowed
options?

E.g. if on node 2 we enter command

phditto -n1

and wish that at node 1 the "phrelay" will run with options like

/usr/photon/bin/phrelay -T 10,3

Thanks
Oleg Khamayko
 


Return to qnx.qnx4

Who is online

Users browsing this forum: No registered users and 2 guests