Skip navigation.
Home
The QNX Community Portal

View topic - sshd wont start automatically during startup

sshd wont start automatically during startup

Read-only archive of qnx.public.sysadmin at inn.qnx.com

Re: sshd wont start automatically during startup

Postby cdm » Tue Jul 06, 2004 5:00 pm

David Bacon <dbacon@qnx.com> wrote:
I don't know why the pseudo-random number generator (at least I
assume that's what PRNG stands for) has not yet "seeded" itself
by the time you try to start sshd in your /etc/rc.d/rc.local
file, but an easy workaround is just to put a "sleep" before the
/opt/sbin/sshd line.


It's actually because the random resmgr is setup with a very limited
set of random sources by default. A better way to start it would
be to do this (on a standard PC):

random -t -p -i14 -i15 -i10 -i12

Which will hook it up to the IDE interrupt lines, the PS/2 interrupt
line and the "normal" NIC interrupt line. The -p option has it
probe /proc for random data.

The default is only to give it -t, which just uses the jitter between
the RTC and the free-running CPU counter to gather random data. You can
edit /etc/rc.d/rc.sysinit to change the options.

chris

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/
cdm
QNX Master
 
Posts: 789
Joined: Fri Jul 05, 2002 9:38 am

Re: sshd wont start automatically during startup

Postby Martin Gagnon » Fri Jan 27, 2006 4:10 pm

Chris McKillop wrote:
It's actually because the random resmgr is setup with a very limited
set of random sources by default. A better way to start it would
be to do this (on a standard PC):

random -t -p -i14 -i15 -i10 -i12

Which will hook it up to the IDE interrupt lines, the PS/2 interrupt
line and the "normal" NIC interrupt line. The -p option has it
probe /proc for random data.

The default is only to give it -t, which just uses the jitter between
the RTC and the free-running CPU counter to gather random data. You can
edit /etc/rc.d/rc.sysinit to change the options.

chris


This is a rather old thread but anyway...
This didn't work here.
I found this to work: 'ls -l /dev' in rc.local, just before
'/opt/sbin/sshd'. It's faster than 'sleep 5'.

I have no idea why it works though. It's strange that 'ls /dev' doesn't
make it...

Martin
Martin Gagnon
 

Previous

Return to qnx.public.sysadmin

Who is online

Users browsing this forum: No registered users and 1 guest