Skip navigation.
Home
The QNX Community Portal

View topic - Qnx4.24-- Install Disk will not boot!

Qnx4.24-- Install Disk will not boot!

Read-only archive of qnx.public.sysadmin at inn.qnx.com

Qnx4.24-- Install Disk will not boot!

Postby eml » Sat Aug 07, 2004 5:07 pm

Hello,

I have a copy of QNX v.4.24 which was purchased for use on a 66MHz 486
system, and ran on that system for a few years. I still have the manuals,
3 11/2 in. and 5 1/4 in floppies, and complete O/S, networking, C
compiler, QNX Windows and DOS emulator. I'd like to load them on a spare
PC, mainly for fun, and general hobby use.

My proiblem is that neither of the boot floppies will boot any of the
Pentium-class systems that I have. I have tried booting on a 166 MHz,
1966 vintage Pentium with 128MB of RAM, configured both as IDE and SCSI
system, with various card configurations right down top bare bones with
1MB SVGA card.

This system will boot and run anything else, from OpenDos 7.1 to Red Hat
Linux 7.3, as well as BeOS4.5 and 5.03 and Coherent without a bit of
trouble. But when I try to boot from the QNX 4.24 factory boot floppy, it
begins to boot, but invariably stops. Using the spinning boot arrow as
somew sort of guide to the boot's progress, and hoping that its "stops"
mean completion of boot stages, I find that it always stops after
completing the twentieth or twenty-first "spin". Both 3.5 inch and 5.25
inch floppies exhibit identical performance. Prior to now, the seal on
the factory 5.25 in. disks had never been broken;they were pristine,

My 266 MHz MMX box and 1900 MHZ Athlon-XP systems, both reliable, and
equally unfussy about booting anything short of the kitchen sink, behave
exactly the same. Can anyone make a suggestion about what's going on here?
I'd really like to get this QNX4 setup going!

Oh, BTW, then I'll start on another antique system with QNX2.13A...

Thanks in advance for any suggestions.

Best regards,
Ed Lukacs
Georgetown, DE
eml
New Member
 
Posts: 2
Joined: Sun Jan 25, 2004 8:00 pm
Location: Georgetown, DE, USA

Re: Qnx4.24-- Install Disk will not boot!

Postby rk » Sat Aug 07, 2004 5:57 pm

Edward Lukacs <eml@ce.net> wrote:
Hello,

I have a copy of QNX v.4.24 which was purchased for use on a 66MHz 486
system, and ran on that system for a few years. I still have the manuals,
3 11/2 in. and 5 1/4 in floppies, and complete O/S, networking, C
compiler, QNX Windows and DOS emulator. I'd like to load them on a spare
PC, mainly for fun, and general hobby use.

My proiblem is that neither of the boot floppies will boot any of the
Pentium-class systems that I have. I have tried booting on a 166 MHz,
1966 vintage Pentium with 128MB of RAM, configured both as IDE and SCSI

1966? Damn, that's older than my PDP-12! LOL!

system, with various card configurations right down top bare bones with
1MB SVGA card.

This system will boot and run anything else, from OpenDos 7.1 to Red Hat
Linux 7.3, as well as BeOS4.5 and 5.03 and Coherent without a bit of
trouble. But when I try to boot from the QNX 4.24 factory boot floppy, it
begins to boot, but invariably stops. Using the spinning boot arrow as
somew sort of guide to the boot's progress, and hoping that its "stops"
mean completion of boot stages, I find that it always stops after
completing the twentieth or twenty-first "spin". Both 3.5 inch and 5.25
inch floppies exhibit identical performance. Prior to now, the seal on
the factory 5.25 in. disks had never been broken;they were pristine,

My 266 MHz MMX box and 1900 MHZ Athlon-XP systems, both reliable, and
equally unfussy about booting anything short of the kitchen sink, behave
exactly the same. Can anyone make a suggestion about what's going on here?
I'd really like to get this QNX4 setup going!

You could try bochs / vmware; they are both emulators of X86 processors;
they might allow you to boot this. I know that at least Bochs allows
you to specify the processor right down to an 8086 if you need to...

Oh, BTW, then I'll start on another antique system with QNX2.13A...

Bochs / vmware may be the only way to go on that. Lemme know if that
works for you, because I'd like to boot QNX 2 / 4 / 6 on bochs on a
freebsd box :-)

Cheers,
-RK

--
[If replying via email, you'll need to click on the URL that's emailed to you
afterwards to forward the email to me -- spam filters and all that]
Robert Krten, PDP minicomputer collector http://www.parse.com/~pdp8/
rk
Senior Member
 
Posts: 172
Joined: Mon Sep 15, 2003 3:58 pm

Re: Qnx4.24-- Install Disk will not boot!

Postby DominiX » Sat Aug 07, 2004 7:27 pm

ici même:cf327v$2d0$1@inn.qnx.com,
Edward Lukacs <eml@ce.net> a écrit
Hello,

I have a copy of QNX v.4.24 which was purchased for use on a 66MHz 486
system, and ran on that system for a few years. I still have the
manuals, 3 11/2 in. and 5 1/4 in floppies, and complete O/S,
networking, C compiler, QNX Windows and DOS emulator. I'd like to
load them on a spare PC, mainly for fun, and general hobby use.

My proiblem is that neither of the boot floppies will boot any of the
Pentium-class systems that I have. I have tried booting on a 166 MHz,
1966 vintage Pentium with 128MB of RAM, configured both as IDE and
SCSI system, with various card configurations right down top bare
bones with 1MB SVGA card.


try some regenerating tools on your floppy disk.
looks like they did not survive so long time.

-- dominix
DominiX
 

Re: Qnx4.24-- Install Disk will not boot!

Postby Gord Sipko » Sun Aug 15, 2004 2:54 pm

Edward,

I had the same problem with my PII-233 - my floppy was OK as it still worked
in a 486DX33. A search through a number of QNX newsgroups/forums pointed to
a problem with the PII floppy controller. There are some controller timing
issues that might be resolved with changes to BIOS settings.

Gord
Gord Sipko
 


Return to qnx.public.sysadmin

Who is online

Users browsing this forum: No registered users and 1 guest