Skip navigation.
Home
The QNX Community Portal

View topic - corrupt QNX V4.25 filesystem

corrupt QNX V4.25 filesystem

For the old QNX2 and QNX4 RTOS

corrupt QNX V4.25 filesystem

Postby WhiteRabbits » Sun Feb 08, 2009 4:16 pm

this harddisk contains a QNX filesystem which was originally installed under V4.25
I start the computer with my QNX V6.21 CD an I can see the original filesystem under /fs/hd0-qnx. one of the folders shows "socket" as filetype, and not "directory".
how can I rectify that ? I need the files from this "former" directory.

regards Helge
WhiteRabbits
Senior Member
 
Posts: 196
Joined: Sun Aug 03, 2003 9:20 pm
Location: Germany

RE: corrupt QNX V4.25 filesystem

Postby juanplacco » Sun Feb 08, 2009 4:45 pm

The same thing happens if you boot directly in QNX 4.25 from the hard disk?
juanplacco
Senior Member
 
Posts: 318
Joined: Wed May 17, 2006 2:30 pm

RE: corrupt QNX V4.25 filesystem

Postby WhiteRabbits » Sun Feb 08, 2009 5:11 pm

when I boot directly from hard disk the boot process is interrupted at a very early stage saying "can not mount /dev/hd0t77 input/output error".
I thought I just copy some important files to a new harddisk and throw the defective one away. unfortunately the files I need are in this "socket" directory.
WhiteRabbits
Senior Member
 
Posts: 196
Joined: Sun Aug 03, 2003 9:20 pm
Location: Germany

RE: corrupt QNX V4.25 filesystem

Postby WhiteRabbits » Sun Feb 08, 2009 5:14 pm

btw a lot of directories and files look very much ok, so I think the damage on the hard disk is not a big one, and chances are I can recover the files I'm looking for.
WhiteRabbits
Senior Member
 
Posts: 196
Joined: Sun Aug 03, 2003 9:20 pm
Location: Germany


Return to QNX2 and QNX4

Who is online

Users browsing this forum: No registered users and 1 guest

cron