Skip navigation.
Home
The QNX Community Portal

View topic - Application in QNX version 4.23A

Application in QNX version 4.23A

For the old QNX2 and QNX4 RTOS

Application in QNX version 4.23A

Postby iromero » Thu Oct 02, 2003 10:01 pm

I´ve an application in QNX version 4.23A, I need to emigrate it to a current version. Is the current version recommendable to my application can work correctly ? . Where I can check the differences between the versions that exist of QNX?
iromero
New Member
 
Posts: 2
Joined: Wed Oct 01, 2003 8:49 pm

Postby cdm » Sat Oct 04, 2003 7:09 pm

Do you want to take it from 4.23A to 4.25 or to QNX6?
cdm
QNX Master
 
Posts: 789
Joined: Fri Jul 05, 2002 9:38 am

QNX version 4.23A to QNX6

Postby iromero » Mon Oct 06, 2003 4:36 pm

I want to take it from 4.23A to QNX6.
iromero
New Member
 
Posts: 2
Joined: Wed Oct 01, 2003 8:49 pm

Postby mario » Sat Oct 11, 2003 7:09 pm

QNX6 is not source or binary compatible with QNX6. The amount of work depend on how QNXish your code is. If it's mostly POSIX is should be fairely simple. If it's full of qnx4 stuff (interrupt, dev*) it can be a pain.

There is a migration kit to help ease porting, I have never used it myself. Prefer to do a clean port.
mario
QNX Master
 
Posts: 4132
Joined: Sun Sep 01, 2002 1:04 am


Return to QNX2 and QNX4

Who is online

Users browsing this forum: Bing [Bot] and 3 guests

cron