Skip navigation.
Home
The QNX Community Portal

View topic - Mouse in not work in QNX 4

Mouse in not work in QNX 4

For the old QNX2 and QNX4 RTOS

Mouse in not work in QNX 4

Postby alexruiz » Wed Mar 04, 2009 10:28 pm

Hi

I have the next problem.

My mouse usb It does not work in realflex

I have a mouse, this is ok, I connect this mouse to my laptop and this is fine.
The mouse is new, and is Microsoft, this is supported for QNX.

I have a hard disc with QNX 4 and the system Realflex 4, this disc was working good mounted in other pc, and my mouse usb is work.

I change this disc to another pc, an Adavantech PC, all components are compatible with QNX.

I start on my pc advantech,and QNX is started, but when I initiate the realfex, my mouse usb is no work.

My usb port in the advantech machine is Ok, for that I start the computer with the disc of Ghost of Syamantec(in a floppy disk), for clone the disk,
my usb mouse is work.

In QNX I have in the sysinit file the line

Input -d /dev/mousein msoft -R fd -d /dev/usbmouse0 &

And in the directory dev I have mounted the usbmouse0

I run the command sin and QNX and this show me usbmouse0
I run the command Mouse test and QNX show me "Unable Server"
If I run the command Mouse test in a shell inside of Realflex this show me "Press left And Right buttons to quit" and I press this bottons and nothing...I don't have good success.

When the QNX is started, the led of the mouse is illuminate.

I change the options in the Bios and I don't have good success.



Someone might help

Regards
alexruiz
New Member
 
Posts: 3
Joined: Wed Nov 19, 2008 6:06 pm

RE: Mouse in not work in QNX 4

Postby panda » Mon Apr 27, 2009 7:49 pm

If you have a /dev/usbmouse0 you should add the line with the Input into the
/etc/config/trap/input.$NODE.
Dont mount it or try to get it working on console level.
If you need it on console level I can send you a proposal running on QNX4.

start only Photon (not ph) and start in Photon a phditto to /dev/con1 wit supressing of the "ditto" message.
Sounds silly, but works ;)
panda
Active Member
 
Posts: 39
Joined: Thu Feb 26, 2004 9:37 am


Return to QNX2 and QNX4

Who is online

Users browsing this forum: No registered users and 2 guests

cron