Skip navigation.
Home
The QNX Community Portal

View topic - V4.25 copying files between Nodes

V4.25 copying files between Nodes

For the old QNX2 and QNX4 RTOS

V4.25 copying files between Nodes

Postby bradanderson » Tue Dec 20, 2011 6:15 pm

I am new to this virtual environment---I am using VMware VSphere 5.0 and setup four QNX guest NODES using drivers Net.e1000 and when I try to copy files between that are 2K or bigger it fails and gives me a error message "Interrupted function call" and then the file does not get transferred. Also an issue with trying to use DITTO to another NODE---error message saying "rem_reply: sender in wrong state". Can somebody assist me on this as these both issues might be related.
Thanks
bradanderson
New Member
 
Posts: 2
Joined: Tue Dec 20, 2011 5:54 pm

Re: V4.25 copying files between Nodes

Postby maschoen » Wed Dec 21, 2011 10:42 am

I don't know what VMware VSphere 5.0 is. I use the free VmWare player. I have no trouble copy files of any size between two VmWare QNX 4.25 systems, or between a VmWare system and a real system. Setting things up can be tricky but once setup there should be no problem.

So I'm not sure what your problem is.
maschoen
QNX Master
 
Posts: 2640
Joined: Wed Jun 25, 2003 5:18 pm

Re: V4.25 copying files between Nodes

Postby bradanderson » Wed Dec 21, 2011 1:52 pm

VMware Vsphere 5.0 is the newest virtual environment platform----------I have a server Dell PowerEdge R810 running Windows server 2008 with the Hypervisor (ESXi) built in----I use vSphere Client 5.0.0 to connect to the VMware vCenter Server 5.0.0 and that is where I create all my guest QNX systems, when I create the guest systems I use the Net.e1000 adaptor for my network. The install goes good but issue I have is FTP or copying files between QNX 4.25 systems that I created (anything more then the 2K). I can transfer files between a guest QNX system and a guest Windows systems no problems and that does not care of the size I send.

So Any thoughts on what I can look at to resolve my issue??
bradanderson
New Member
 
Posts: 2
Joined: Tue Dec 20, 2011 5:54 pm

Re: V4.25 copying files between Nodes

Postby patmon » Wed Apr 25, 2012 6:27 pm

I had the same problem using VMWare ESXi 5. I was able to solve that by setting the adaptor type of my QNX4 guest to "flexible" and by using the Net.ether2100 driver.
patmon
New Member
 
Posts: 2
Joined: Wed Apr 25, 2012 6:21 pm


Return to QNX2 and QNX4

Who is online

Users browsing this forum: No registered users and 2 guests

cron