Skip navigation.
Home
The QNX Community Portal

View topic - External USB Hard Drive

External USB Hard Drive

For the old QNX2 and QNX4 RTOS

External USB Hard Drive

Postby MisDept » Thu Dec 13, 2012 12:36 am

QNX 4.25 installed with 2011 Release.
Installed USB Stack V2.00K (tho I had the same issues below, before this patch).

I connect a USB hard drive (one a 2TB G-Tech, SATA I believe; the other an old 20gb PATA IDE via IDE-to-USB adapter).
I've connected both a flash drive and a CF Reader to two ports, and they were seen - but I don't remember now if I was able to access files.
Run io-usb &
Get /dev/usb

Run usb -vvv
The device (either) is recognized.
****************************
USB 0 (UHCI) v1.10, v1.01 DDK, v1.01 HCD
Control, Interrupt, Bulk, Isoch, Low speed

Device Address : 1
Upstream Host Controller : 0
Upstream Device Address : 0
Upstream Port : 0
Upstream Port Speed : Full
Vendor : 0x4971 (G-TECH)
Product : 0xce33 (G-DRIVE)
Device Release : r2.05
USB Spec Release : v2.00
Serial Number : EB42009V
Class : 0x00 (Independant per interface)
Max PacketSize0 : 64
Languages : 0x0409 (English), 0x041a
Current Frame : 542 (1024 bytes)
Configurations : 1
Configuration : 1 (Config0)
Attributes : 0xc0 (Self-powered)
Max Power : 0 mA
Interfaces : 1
Interface : 0 / 0 (Interface0)
Class : 0x08 (Mass Storage)
Subclass : 0x06 (SCSI)
Protocol : 0x50
Endpoints : Control + 2
Endpoint : 0
Attributes : Control
Max Packet Size: 64
Endpoint : 1
Attributes : Bulk/OUT
Max Packet Size: 64
Endpoint : 1
Attributes : Bulk/IN
Max Packet Size: 64
************************************

run Fsys.umass fsys
Get Path=0 - QNX USB Storage
target=0 lun=0 Direct-Access(0) - Ext Hard Disk Rev:

Get hd0 added to /dev/.

If I run just 'Fsys.umass' after io-usb...
Get [000] SIM="" HBA="QNX USB Storage"
[00,0,0] type=00 ver-05 resp=02 flags=00 Ext Hard Disk

Nothing new is added to /dev/.
(nor to /dos/ - I checked just in case)

Run Fsys.umass -v fsys -N usb -n usb0 &
I get the /dev/usb0

But if I try to fdisk either usb0 or hd0 device (fdisk /dev/usb0 delete, add, show, info) -
I get: //1/bin/fdisk terminated (SIGFPE ) at 0007:0000xxxx
%2 xxx Floating exception fdisk /dev/usb0 show "Floating exception"

I also tried:
Fsys.umass -l -n Direct-Access=hd
and other combinations I've found online - most don't create any new device.

Dinit won't work as Block 1 not found ("not formatted?").

Both hard drives work fine on a Windows XP station.
I deleted the NTFS partition on the 2TB drive - now has NO partition, and I get the same error.

I can insert a small 64k flash drive into the same port and run these commands - then fdisk works fine.

Any idea, please, why these external USB hard drives aren't working?

Thx
MisDept
Active Member
 
Posts: 17
Joined: Tue May 17, 2005 7:28 pm

Re: External USB Hard Drive

Postby epboyd » Thu Dec 13, 2012 11:44 pm

This works for me to mount FAT32 formatted USB flash drives. Note only the use of one partition.

Fsys.umass -v fsys -Nusb -nusb0.
mount -p /dev/usb0.0
Fatfsys
epboyd
New Member
 
Posts: 6
Joined: Sun Dec 09, 2012 1:54 am

Re: External USB Hard Drive

Postby MisDept » Fri Dec 14, 2012 2:11 am

Thx for the input.
Yes - I too can mount USB flash drives with no problem.
I just can't get USB hard drives to work??
I'm not getting the subtle differences between these two devices in QNX 4.25. :-(
MisDept
Active Member
 
Posts: 17
Joined: Tue May 17, 2005 7:28 pm

Re: External USB Hard Drive

Postby Tim » Fri Dec 14, 2012 6:34 pm

Maybe QNX 4.25 can't handle a drive that's 2 TB in size. That's HUGE compared to the size of drives that were available back when 4.25 was initially released.

Even under QNX 6 I find it can take 30+ seconds or more to mount a 500 Gig drive because of how the QNX filesystem works. I tend to partition drives into one 30 Gig partition so it boots fast and leave the rest unused.

Any chance you can partition it into a drive of more manageable size maybe one 250 or 500 Gig partition and then the rest in another partition.

Tim
Tim
Senior Member
 
Posts: 1388
Joined: Wed Mar 10, 2004 12:28 am

Re: External USB Hard Drive

Postby epboyd » Wed Dec 19, 2012 2:30 pm

epboyd
New Member
 
Posts: 6
Joined: Sun Dec 09, 2012 1:54 am

Re: External USB Hard Drive

Postby MisDept » Wed Dec 19, 2012 6:16 pm

I thought of the size issue also, so I connected a 20gb PATA via IDE-to-USB adapter - and got the same problems. :-(
MisDept
Active Member
 
Posts: 17
Joined: Tue May 17, 2005 7:28 pm

Re: External USB Hard Drive

Postby MisDept » Wed Dec 19, 2012 6:57 pm

Thanks for the link - good to know!


MisDept
Active Member
 
Posts: 17
Joined: Tue May 17, 2005 7:28 pm


Return to QNX2 and QNX4

Who is online

Users browsing this forum: No registered users and 3 guests