Skip navigation.
Home
The QNX Community Portal

View topic - How to improve HTML support in QNX4.25?

How to improve HTML support in QNX4.25?

For the old QNX2 and QNX4 RTOS

How to improve HTML support in QNX4.25?

Postby lullaby » Mon Nov 17, 2014 6:52 am

Dear all,

As mentioned in an earlier post, we are still working hard to find out how we can improve the HTML version support in QNX4.25.
Our exact usecase is we need to display some html files in 'local filesystem'

We have read about Voyager SDK as in link http://www.qnx.com/developers/qnx4/qnx4 ... ?code=6374
and http://www.embed.com.cn/2993CFA7-951B-4 ... oyager.pdf.
Understood that Voyager SDK has HTML3.2 support and also supports PtWebClient.
Also as per http://www.schoenbrun.com/mba/faq.htm#L21, Maschoen mentioned about Internet Appliance Toolkit Development CD which includes Voyager SDK.
We have some queries regarding these findings:-

1. Our assumption is:
a. QNX 4.25 supports HTML1.1 by default.
b. If we buy Voyager SDK and integrate it with QNX4.25, we will get PtWebClient support as well as HTML3.2 support.
Is our assumption correct?

2. Do we exactly need Voyager SDK for displaying html 3.2 files on local filesystem? I mean, is voyager SDK designed for some complex usecase like displaying html files on remote machines?

3. As per PtWebClient help page, it is mentioned that PtWebClient transparently supports the version of HTML that the server supports.
So we assume we need to buy Voyager SDK to get PtWebClient support on QNX4.25. After getting PtWebClient working on QNX4.25, can we adjust the backend server on it to some other server such as mozilla server or opera server to get HTML4 support on QNX4.25.
Is this assumption correct?

Please shed some light to our concerns...
Thank you for your understanding and patience...

Regards,
Lullaby
lullaby
Active Member
 
Posts: 82
Joined: Fri Jun 15, 2012 6:19 am

Re: How to improve HTML support in QNX4.25?

Postby maschoen » Mon Nov 17, 2014 9:12 am

lullaby wrote:Dear all,
Also as per http://www.schoenbrun.com/mba/faq.htm#L21, Maschoen mentioned about Internet Appliance Toolkit Development CD which includes Voyager SDK.

This faqs is extremely old at this time, and I would not think it has any accuracy at this time.

We have some queries regarding these findings:-

1. Our assumption is:
a. QNX 4.25 supports HTML1.1 by default.
b. If we buy Voyager SDK and integrate it with QNX4.25, we will get PtWebClient support as well as HTML3.2 support.
Is our assumption correct?

This is very old technology. I would check with QNX on all of this. I doubt that the Voyager SDK is still available, but you should check and see.
2. Do we exactly need Voyager SDK for displaying html 3.2 files on local filesystem? I mean, is voyager SDK designed for some complex usecase like displaying html files on remote machines?

The SDK is designed to render html files in Photon. The html files could come from a remote web server or be local files. The SDK would allow you to build your own custom browser. I would be suspicious about its support for things like PNG files.

3. As per PtWebClient help page, it is mentioned that PtWebClient transparently supports the version of HTML that the server supports.


Well, as I recall there were three engines supported. This is for QNX 6. There was a "Spyglass" engine which was the basis for voyager. This is the only engine that I know supported the PtWebClient as documented. Later, there was a port of Firefox which used a different engine, a port from Mozilla. This did not support all the PtWebClient features as documented. There was a third engine mentioned in the documentation, however I think this was only available as an extra. I don't recall it's purpose. Maybe something to do with embedded systems. In any case, I never saw it in operation so I don't know if it supported all the PtWebClient interface features or not.

Keep in mind this is QNX 6 with Photon 2 I'm talking about. The same software on QNX 4.25 is a mystery to me.

So we assume we need to buy Voyager SDK to get PtWebClient support on QNX4.25. After getting PtWebClient working on QNX4.25, can we adjust the backend server on it to some other server such as mozilla server or opera server to get HTML4 support on QNX4.25.
Is this assumption correct?


You really have to talk with QNX directly about this with respect to what exists, what level of HTML is supported and whether it is available for purchase any longer. I have lots of doubts about all three. Unless you are really backed into a corner, I would suggest looking at other options. For example, could you convert your HTML to PDF files? Someone built or ported a reasonable PDF viewer to Photon, and this work might be back ported to Photon 1.14.
maschoen
QNX Master
 
Posts: 2640
Joined: Wed Jun 25, 2003 5:18 pm

Re: How to improve HTML support in QNX4.25?

Postby lullaby » Wed Nov 19, 2014 4:59 am

Thank you, Maschoen for the valuable response.

Regards,
Lullaby
lullaby
Active Member
 
Posts: 82
Joined: Fri Jun 15, 2012 6:19 am


Return to QNX2 and QNX4

Who is online

Users browsing this forum: No registered users and 3 guests

cron