Skip navigation.
Home
The QNX Community Portal

View topic - QNX4 photon can't load

Page 1 of 1

QNX4 photon can't load

PostPosted: Wed Oct 05, 2016 4:46 am
by sieudot
Hi,

I have some photon applications running on QNX 4.25, on Compact Flash.
They were run ok. But the problem is: I unplug the Compact Flash from board to backup it by using a sector-by-sector copy tool.
The copy process has done successfully and very carefully.
Then, I plug it back to board and boot, it only boot to console and not load Photon.
I think this "photon" has been corrupted, so, I open file-system and replace all directory "/qnx4/photon" by other "good" photon directory.
Reboot, it loads photon and my application ok, but some special character can't not be displayed (ex. Greek character: Kappa, Psi, Lamda..).

So, my questions are: how to display Greek characters on Photon? What font do I need to install or copy to fix that?

Re: QNX4 photon can't load

PostPosted: Thu Oct 06, 2016 1:41 pm
by Linkman
If the /qnx4/photon directory that you copied from is good and your copy operation went successfully then it should have loaded the fonts that you need. I suspect that you either have a problem with licensing (QNX 4 can be sensitive to attempts to copy licenses) or your graphics reverted to a mode that cannot display those fonts.

Does your photon display configuration show that you are using the expected driver family, driver, resolution, and color depth? Are you using Phindows to access this (Phindows often does not show special fonts)?

Some of the photon settings are often set using files in /.photon. That directory is easily missed during copying.

Run a "licinfo -a" command and post the results here. You may also want to run a "chkfsys -u /"to check the file system integrity. It sounds like your sector by sector copy did not work correctly.

Re: QNX4 photon can't load

PostPosted: Fri Oct 07, 2016 2:55 am
by sieudot
Thank you, Linkman,

With font problem, I found my mistake, this cause by wrong replace fontdir, fontext, fontmap, fontopt files in folder "/qnx4/photon/font". I have restored all this original ones, and then Photon can display Greek characters well.

Linkman wrote:If the /qnx4/photon directory that you copied from is good and your copy operation went successfully then it should have loaded the fonts that you need. I suspect that you either have a problem with licensing (QNX 4 can be sensitive to attempts to copy licenses) or your graphics reverted to a mode that cannot display those fonts.

Does your photon display configuration show that you are using the expected driver family, driver, resolution, and color depth? Are you using Phindows to access this (Phindows often does not show special fonts)?

Some of the photon settings are often set using files in /.photon. That directory is easily missed during copying.

Run a "licinfo -a" command and post the results here. You may also want to run a "chkfsys -u /"to check the file system integrity. It sounds like your sector by sector copy did not work correctly.