Skip navigation.
Home
The QNX Community Portal

View topic - boot QNX v4.25

Page 1 of 1

boot QNX v4.25

PostPosted: Sat Mar 04, 2017 11:54 am
by sowhat
Hello. Please, I need a help. I cant boot device with qnx 4.25 OS after I changed cmos battery. Im not professional programmer, pls, give me instruction, what can I do with it. :?: :?: :cry:

Re: boot QNX v4.25

PostPosted: Sat Mar 04, 2017 11:23 pm
by maschoen
sowhat wrote:Hello. Please, I need a help. I cant boot device with qnx 4.25 OS after I changed cmos battery. Im not professional programmer, pls, give me instruction, what can I do with it. :?: :?: :cry:


So it is clear that the QNX boot file is being loaded into memory and it executes. What I think happens next is that the file system runs and the EIDE driver runs. The disk is then mounted as root, and finally the startup process tries to run /bin/sh off the hard drive, but it doesn't find it. It's trying to run your /etc/sysinit file.

The reason for this is probably that your BIOS has the hard drive mis-configured. This used to happen a lot with QNX 2. By the time QNX 4 was out, a lot of EIDE drives had LBL (Logical Block addressing) so there was no way to mess up the Head/Track/Cylinder configuration in the BIOS. But I think your system might be pre-LBL causing the problem. If that's so, it's a little odd that the boot works at all, however even with wrong H/T/C, if the boot file is in the first cylinder, it often works.

I suggest you find out what model your hard drive is, Google it and find what it's H/T/C parameters are and set them in the BIOS.

Re: boot QNX v4.25

PostPosted: Wed Mar 08, 2017 3:58 pm
by sowhat
maschoen wrote:
sowhat wrote:Hello. Please, I need a help. I cant boot device with qnx 4.25 OS after I changed cmos battery. Im not professional programmer, pls, give me instruction, what can I do with it. :?: :?: :cry:


So it is clear that the QNX boot file is being loaded into memory and it executes. What I think happens next is that the file system runs and the EIDE driver runs. The disk is then mounted as root, and finally the startup process tries to run /bin/sh off the hard drive, but it doesn't find it. It's trying to run your /etc/sysinit file.

The reason for this is probably that your BIOS has the hard drive mis-configured. This used to happen a lot with QNX 2. By the time QNX 4 was out, a lot of EIDE drives had LBL (Logical Block addressing) so there was no way to mess up the Head/Track/Cylinder configuration in the BIOS. But I think your system might be pre-LBL causing the problem. If that's so, it's a little odd that the boot works at all, however even with wrong H/T/C, if the boot file is in the first cylinder, it often works.

I suggest you find out what model your hard drive is, Google it and find what it's H/T/C parameters are and set them in the BIOS.


Thank you. I did it, but it would not work. What can I do else?

Re: boot QNX v4.25

PostPosted: Wed Mar 08, 2017 6:24 pm
by maschoen
I think at this point you probably need professional help. Can you contact the people who created the system? Do you have a backup? There are all sorts of things that could be wrong. It could be as simple as the /bin/sh file being corrupted, but to figure out might be challenging.

Re: boot QNX v4.25

PostPosted: Wed Mar 08, 2017 6:52 pm
by Tim
Changing the CMOS battery will have wiped out the settings in the BIOS from what they were.

While Mitchell is right that it could be the /bin/sh file corrupted it seems equally or more likely something isn't set right in the BIOS.

Do you have another of these machines where you could check the BIOS settings on and compare to what you have now in your machine that isn't working?

What BIOS do you have and what changeable settings are there under IDE/Sata etc? Do you have a RAID configuration? That's the most likely place something is different from before and now.

Tim

Re: boot QNX v4.25

PostPosted: Thu Mar 09, 2017 2:53 am
by sieudot
sowhat wrote:Hello. Please, I need a help. I cant boot device with qnx 4.25 OS after I changed cmos battery. Im not professional programmer, pls, give me instruction, what can I do with it. :?: :?: :cry:



What is your current CPU and harddisk?
Tim is right. Your BIOS configuration has been lost. You must restore it. Try to change BIOS, special on harddisk configuration.