Skip navigation.
Home
The QNX Community Portal

View topic - Problem with graphics driver QNX 6.5.0

Problem with graphics driver QNX 6.5.0

Discussion about the QNX6 OS.

Problem with graphics driver QNX 6.5.0

Postby ogr » Mon Mar 07, 2011 12:56 pm

Hello everybody.

I'm trying to update to QNX 6.5.0 from QNX 6.3.2.

I've downloaded the "QNX SDP for x86 Targets 6.5.0.Neutrino Hosts" and burnt it to a CD.
Then I boot and run from de CD (selecting F2 option) and but it fails starting Photon and gives the following message:

Copied "/usr/photon/config/crtc-settings" to "/etc/system/config/crtc-settings"
Starting extra run commands
Unable to start graphics driver(s)


After that it ask for the "login" to start in console mode.

Any idea where is the problem?
This harware was working succesfully with QNX 6.3.2. Neutrino Host.

Thanks

ogr
ogr
Active Member
 
Posts: 28
Joined: Thu May 31, 2007 1:16 pm

RE: Problem with graphics driver QNX 6.5.0

Postby maschoen » Tue Mar 08, 2011 10:21 am

You didn't say what the hardware is. I found out the hard way that 6.5 does not include the Voodoo card driver. Of course the Vesa driver did work in it's crappy manner. I found out the source can be compiled, but I haven't gotten around to it.
maschoen
QNX Master
 
Posts: 2644
Joined: Wed Jun 25, 2003 5:18 pm

Postby ogr » Tue Mar 08, 2011 12:11 pm

I found out the problem.

In the "display.conf" file the Photon drivername was set to svga. Changing it to i830 (that is my hardware) the system boot and Photon starts and ask for graphics configuration, as normal.

What I don't understand is why doesn't Photon start by itself. It is not suppossed that it must detect and configure the right graphic hardware?

It does in QNX 6.3.

Anyway, thanks maschoen.

ogr
ogr
Active Member
 
Posts: 28
Joined: Thu May 31, 2007 1:16 pm

Postby qnxloader » Wed Mar 09, 2011 9:39 am

for 6.3.0:
/etc/system/enum/devices/graphics:

device(pci, ven=8086, dev=3577, index=0) # Intel 82830
device(pci, ven=8086, dev=3582, index=0) # Intel 82852/82855
device(pci, ven=8086, dev=2562) # Intel 82845
device(pci, ven=8086, dev=2572) # Intel 82865
cfgfile(fname, /etc/system/config/graphics-traplist)
echo(devgt-iographics -dldevg-i830.so -I$(index) "-d0x$(ven),0x$(dev)", $(fname))
echo(devgt-iographics -dldevg-vesabios.so -I$(index) "-d0x$(ven),0x$(dev)", $(fname))
echo(devgt-iographics -dldevg-svga.so -I$(index) "-d0x$(ven),0x$(dev)", $(fname))

for 6.5.0:
start/wait( dispconf -i "0x$(ven),0x$(dev),$(index)" -d svga -d i830 -d vesabios )
requires/wait( $(IODISPLAY_CMD), )
mount(-Tio-display "vid=0x$(ven),did=0x$(dev),deviceindex=$(index)" )

for 6.3.0 i830 starting by default, for 6.5.0 - svga.
edit line
start/wait( dispconf -i "0x$(ven),0x$(dev),$(index)" -d svga -d i830 -d vesabios )
to
start/wait( dispconf -i "0x$(ven),0x$(dev),$(index)" -d i830 -d vesabios -d svga)
and i830 will be starting by default(delete display-conf first).
qnxloader
Senior Member
 
Posts: 206
Joined: Mon Oct 06, 2003 8:29 am


Return to QNX6 - OS

Who is online

Users browsing this forum: No registered users and 2 guests