Skip navigation.
Home
The QNX Community Portal

View topic - Library Linking Issue with QNX 6.5.0

Library Linking Issue with QNX 6.5.0

Discussion about the QNX6 OS.

Library Linking Issue with QNX 6.5.0

Postby Manishk31 » Thu Aug 18, 2011 9:59 am

Hi,

I have created a QNXC++ project and in the build, I want to link few external libraries.
I have specified the path and these libraries in the linker tab(right click on QNX project --> Properties --> QNXC/C++ Project --> Linker)

While compilation the ld cannot find the external libraries though I have specified the path and library name:

Any suggestions to fix this problem would be helpful

--------------------ERROR START----------------------------------

C:/QNX650/host/win32/x86/usr/bin/rm -f C:/ide-4.7-workspace/RHPQNXEclipsePrj/x86/o-g/RHPQNXEclipsePrj_g
C:/QNX650/host/win32/x86/usr/bin/qcc -Vgcc_ntox86 -lang-c++ -lang-c++ -Bstatic -oC:/ide-4.7-workspace/RHPQNXEclipsePrj/x86/o-g/RHPQNXEclipsePrj_g Building.o Door.o Elevator.o ElevatorPkg.o GuiPkg.o IHardware.o Itinerary.o Mainhost.o Motor.o RHPQNXEclipsePrj.o guiDlg.o sys.o -L . -L C:/Rhapsody76/Share/LangCpp/lib -L C:/QNX650/target/qnx6/x86/lib -L C:/QNX650/target/qnx6/x86/usr/lib -Wl,--rpath-link . -Wl,--rpath-link C:/Rhapsody76/Share/LangCpp/lib -Wl,--rpath-link C:/QNX650/target/qnx6/x86/lib -Wl,--rpath-link C:/QNX650/target/qnx6/x86/usr/lib -lQNXCWaomanimx86.a -lQNXCWaomtracex86.a -lQNXCWomcomapplx86.a -lQNXCWoxfinstx86.a -lQNXCWoxfx86.a -lQNXCWtomtraceRiCx86.a -lQNXCWtomtracex86.a -lQNXCWWebComponentsx86.a -g
C:\QNX650\host\win32\x86\usr\bin\ntox86-ld: cannot find -lQNXCWaomanimx86.a
make.exe[2]: Leaving directory `C:/ide-4.7-workspace/RHPQNXEclipsePrj/x86/o-g'
cc: C:/QNX650/host/win32/x86/usr/bin/ntox86-ld caught signal 1
make.exe[1]: Leaving directory `C:/ide-4.7-workspace/RHPQNXEclipsePrj/x86'
make.exe[2]: *** [C:/ide-4.7-workspace/RHPQNXEclipsePrj/x86/o-g/RHPQNXEclipsePrj_g] Error 1
make.exe[2]: Target `all' not remade because of errors.
make.exe[1]: [all] Error 2 (ignored)

-----------------------------ERROR END---------------------------------------------
Attachments
LinkerError.jpg
(75 KiB) Not downloaded yet
Manishk31
New Member
 
Posts: 2
Joined: Thu Aug 18, 2011 9:12 am

Re: Library Linking Issue with QNX 6.5.0

Postby Manishk31 » Thu Aug 18, 2011 2:10 pm

thank you, the problem is fixed
Manishk31
New Member
 
Posts: 2
Joined: Thu Aug 18, 2011 9:12 am


Return to QNX6 - OS

Who is online

Users browsing this forum: No registered users and 2 guests