Skip navigation.
Home
The QNX Community Portal

View topic - System Information Utility

System Information Utility

Discussion about the QNX6 OS.

System Information Utility

Postby rashidmirza » Wed Dec 07, 2011 12:36 pm

i have been trying to load a driver using the System Information utility in qnx (6.3.0).
I did the following:

File -> Open (navigated to /sbin folder)
and did a load of devc-pty.
This will not load the devc-pty and i get a message on the lower bottom of the window:

"unable to access node /proc"

Does anyone know why this is happening?
Also, if i the load through System Process Inspector works, how can i pass arguments to the load, for example as below:

devc-pty -n 32


this question is related to one of my other posts on this forum, and this question has been posted, because i am looking at alternative methods to load the devc-pty, since i no longer can open a terminal window.
rashidmirza
Active Member
 
Posts: 55
Joined: Sun Jun 13, 2010 4:32 am

Re: System Information Utility

Postby Thunderblade » Wed Dec 07, 2011 2:17 pm

I'm not sure what you mean. Are you using the System Information Perspective of Momentics, and in there the Target Filesystem View?

I haven't worked with 6.3 for many years (I think it's over 5 years old) but in 6.5 I would use the Target Filesystem View, right-click on the executable and click "Run". Did you mean this when you say you "did a load"?

After clicking "Run" the IDE asks for "application parameters" where you can add command line arguments.
Thunderblade
Senior Member
 
Posts: 487
Joined: Thu Apr 07, 2005 11:52 am

Re: System Information Utility

Postby rashidmirza » Thu Dec 08, 2011 4:34 am

i have attached two screen dumps of what i meant in my previous post.
Attachments
screenshot2.JPG
details after opening system information
(146.14 KiB) Not downloaded yet
screenshot1.JPG
gui of qnx
(91.64 KiB) Not downloaded yet
rashidmirza
Active Member
 
Posts: 55
Joined: Sun Jun 13, 2010 4:32 am

Re: System Information Utility

Postby maschoen » Thu Dec 08, 2011 6:00 am

The program you are using, "System Process Inspector" is just that, an "inspector". That is not how you "load" devc-pty. While devc-pty is a driver, it is a program/process. You can start it from a command line. However since you have Photon running, it seems like it must already be running.

So the question becomes why do you think you need to load/start devc-pty?
maschoen
QNX Master
 
Posts: 2640
Joined: Wed Jun 25, 2003 5:18 pm

Re: System Information Utility

Postby rashidmirza » Thu Dec 08, 2011 7:01 am

i have a topic in the forum :

"re-run devc-pty"

where the issue is that, devc-pty is consuming CPU. I slay the process. After slaying, the CPU drops, but i cannot open any terminal window, or telnet to that machine.
This the reason why i want to run devc-pty, but since i cannot open a terminal window or telnet, is becoming challenging to think of ways to run a process.
rashidmirza
Active Member
 
Posts: 55
Joined: Sun Jun 13, 2010 4:32 am


Return to QNX6 - OS

Who is online

Users browsing this forum: No registered users and 1 guest