Skip navigation.
Home
The QNX Community Portal

View topic - i830 driver

i830 driver

Discussion about the QNX6 OS.

i830 driver

Postby ingraham » Thu May 09, 2013 8:13 pm

So I have a single board computer with an Intel Atom with built-in video support. It works flawlessly in QNX 4.25 using the i830 driver. However, I'm having trouble with it in QNX 6.3.2. The device ID isn't listed in the /etc/system/enum/devices/graphics file, so I added an overrides file with essentially the same information as the graphics file entry for the i830, but with only one line for the device ID of a011. When the system starts, it correctly identifies the card and tries to run the devg-i830 driver, but says "mode switcher init: invalid argument." i830 does not show up in the graphics-modes file, and thus isn't available as a choice in phgrafx. I tried manually adding the lines to the graphics-modes file, but when I actually tried the driver photon just died. (And yes, I waited the 15 seconds to see if it would revert.) Am I just out of luck here, or is there something else I could try to make this work?

Thanks,
James
ingraham
Senior Member
 
Posts: 160
Joined: Wed Nov 05, 2003 2:25 pm
Location: Texas

Re: i830 driver

Postby maschoen » Fri May 10, 2013 3:41 am

Here's a long shot. Download i830.tar and de-archive and try this this version. Keep the old version.
Attachments
i830.tar
(159.5 KiB) Downloaded 143 times
maschoen
QNX Master
 
Posts: 2640
Joined: Wed Jun 25, 2003 5:18 pm

Re: i830 driver

Postby denkelly » Fri May 10, 2013 11:12 am

Might try gma9xx
denkelly
Senior Member
 
Posts: 160
Joined: Sat Aug 02, 2008 3:27 pm

Re: i830 driver

Postby ingraham » Mon May 13, 2013 11:31 pm

@maschoen: Thanks for the effort, but the result was the same.

@denkelly: My 6.3.2 version does not appear to have a GMA9xx driver.

Thanks anyway, guys.

-James Ingraham
ingraham
Senior Member
 
Posts: 160
Joined: Wed Nov 05, 2003 2:25 pm
Location: Texas

Re: i830 driver

Postby maschoen » Mon May 13, 2013 11:36 pm

Interesting. I was working on a project with a custom designed embedded system. On the first round, the i830 driver didn't work. We got an updated one from Dennis and it worked. That's the one I sent to you. I think it's been since incorporated into 6.5.0. It does seem odd that it doesn't work for you.
maschoen
QNX Master
 
Posts: 2640
Joined: Wed Jun 25, 2003 5:18 pm

Re: i830 driver

Postby ingraham » Wed May 15, 2013 7:16 pm

Yeah, I had high hoped, especially since the i830 driver in 4.25 works so well.
ingraham
Senior Member
 
Posts: 160
Joined: Wed Nov 05, 2003 2:25 pm
Location: Texas

Re: i830 driver

Postby space » Fri Aug 30, 2013 4:12 pm

I had a similar problem getting a Intel Mobile 945 chip working. I found this: http://foundry27.com/sf/discussion/do/listPosts/projects.bsp/discussion.bsp.topc17654?_pagenum=2.
The modified i830 driver works for my video chip.
Maybe it will work for you too.
space
Active Member
 
Posts: 16
Joined: Fri Mar 09, 2007 6:03 pm
Location: Texas


Return to QNX6 - OS

Who is online

Users browsing this forum: No registered users and 4 guests

cron