Skip navigation.
Home
The QNX Community Portal

View topic - delayed ping

delayed ping

Discussion about the QNX6 OS.

delayed ping

Postby WhiteRabbits » Wed Nov 13, 2013 11:01 pm

- on some machines when I issue a ping command, it takes approx. 15 seconds until the first ping telegam goes out. do I have to worry about that ?

- starting phlip, I get a popup-window telling me that 'netmanager terminated abnormally'; after this, the usual phlip window opens and I can modify the entries; when I apply the changes, the /etc/net.cfg file is correctly written. This file contains about > 60 routing entries, otherwise it looks standard to me. Does anyone know about restrictions ? I can't find any in the docs.

Helge
WhiteRabbits
Senior Member
 
Posts: 196
Joined: Sun Aug 03, 2003 9:20 pm
Location: Germany

Re: delayed ping

Postby maschoen » Thu Nov 14, 2013 1:28 am

Why not remove most of the routing info (temporarily) and see if the problem goes away. If it does, you probably will need to talk to QNX about the problem.

It seems like one of those bugs that doesn't appear until you do something a little differently, and being the first to run into the problem, it seems strange.
maschoen
QNX Master
 
Posts: 2644
Joined: Wed Jun 25, 2003 5:18 pm

Re: delayed ping

Postby qnxloader » Thu Nov 14, 2013 8:04 am

maschoen wrote:It seems like one of those bugs that doesn't appear until you do something a little differently, and being the first to run into the problem, it seems strange.


He is not one, I am too have delayed first ping on some computers.
qnxloader
Senior Member
 
Posts: 206
Joined: Mon Oct 06, 2003 8:29 am

Re: delayed ping

Postby WhiteRabbits » Thu Nov 14, 2013 9:10 am

As to the second issue (netmanager) I'll have a look by myself, making routing entries in portions of 10 and restarting.

The delayed ping is not a big issue for me, I was just wondering why. The QNC PC has practically no load, but it seems it's silently contemplating whether to perform the task or not. Some people (age < 30) get nervous when they have to wait for something, and my task is to keep them in good mood.

Helge
WhiteRabbits
Senior Member
 
Posts: 196
Joined: Sun Aug 03, 2003 9:20 pm
Location: Germany

Re: delayed ping

Postby Tim » Thu Nov 14, 2013 5:41 pm

If you have a nameserver specified then QNX will attempt to contact that nameserver before doing the ping. This happens even if you specify a specific IP address like 192.168.0.1.

It's highly annoying if that nameserver isn't resolvable because it can take up to 45 seconds to time out before the first ping occurs.

If you remove the nameserver then the pings happen immediately.

Tim
Tim
Senior Member
 
Posts: 1392
Joined: Wed Mar 10, 2004 12:28 am

Re: delayed ping

Postby WhiteRabbits » Thu Nov 14, 2013 9:35 pm

Good to know that, I don't have to worry then.

As to the 'netmanager' problem I make 47 entries into the routing table, each one with an 'Apply'. The error message comes up with the 48th entry and 'Apply'.
I delete the 48th entry, the message still pops up. I restart the system and (staying at < 47 entries) the message won't appear. Apart from that, I do not notice any fault in the system and it's tcpip communication, seems to me it's just a message.

Speaking for myself, this topic is closed. Thanks for the help.
Helge
WhiteRabbits
Senior Member
 
Posts: 196
Joined: Sun Aug 03, 2003 9:20 pm
Location: Germany


Return to QNX6 - OS

Who is online

Users browsing this forum: No registered users and 3 guests

cron