Skip navigation.
Home
The QNX Community Portal

View topic - QNX 6.6 for VMWare error no gpu support

QNX 6.6 for VMWare error no gpu support

Discussion about the QNX6 OS.

QNX 6.6 for VMWare error no gpu support

Postby chip8xvn » Sat Aug 29, 2015 10:26 pm

Hi all !
I'm a newbie.Today, i learn about QNX and want to run a Qt5 OpenGL program on it.
I have taken the following steps :
- Step 1 : I installed qnx-sdp-6.6, qnx-sdk-for-apps-and-media and qt-5.3.1 (QNX) on windows host.Then i installed patch-660-3875-660-Graphics-GA with applypatch command.
- Step 2 : I used QNX SDP 6.6 runtime ISO for VMWare.Links download here : http://www.qnx.com/download/feature.htm ... amid=26217 .I installed with many options : Guest operating systems : Other.Version : Other.Memory : 2GB.Hard Disk (IDE) : 20GB.
- Step 3 : I copied the files to VMWare guided in link : http://www.qnx.com/developers/articles/rel_5948_26.html
- Step 4 : power on QNX on VMWare then i login with root by command :
login root
then export environment path
export GRAPHICS_ROOT=/usr/lib/graphics/vmware
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$GRAPHICS_ROOT
And i echo $GRAPHICS_ROOT, result /usr/lib/graphics/vmware
And i echo $LD_LIBRARY_PATH, result usr/lib:/lib:/lib/dll:/usr/lib/graphics/vmware
- Step 5 : i power off my virutal machine and i enable 3D graphics on VMWare settings -> Display but i have warning 3D accelerations is not supported in this guest operating system.
- Step 6 : i power on my virtual machine and run commands :
gpu_drv
screen
i found a error here : libEGL warning : no gpu support.I found a fix : "It's likely that the "Accelerate 3D Graphics" setting was not selected" but i did enable in step 5.Anyone can help me fix it ? Thanks for helping me.I'm sorry for my bad english.

I tried deploy Qt5 library to my virtual machine by Deploy Qt tools.Then i created Qt Widget project and build it with QNX Kits :
- Complier : C:\qnx660\host\win32\x86\usr\bin\qcc.exe
- Debuggers : C:\qnx660\host\win32\x86\usr\bin\ntox86-gdb.exe
- Qt Versions : Qt 5.3.1-x86 with QNX SDP C:\qnx660
Then i copied file program to my QNX virtual machine and run it.Error : memory fault (core dumped).Can anyone guide me how to deploy Qt5 for QNX VMware ?
chip8xvn
New Member
 
Posts: 1
Joined: Sat Aug 29, 2015 10:24 am

Re: QNX 6.6 for VMWare error no gpu support

Postby Tim » Mon Aug 31, 2015 3:25 pm

See this link for enabling 3D acceleration in a VMWare image

http://www.qnx.com/developers/articles/ ... tml#VMWARE

You appear to have done Steps 1-3. Likely you need to copy all the files in Steps 4-5.

Tim
Tim
Senior Member
 
Posts: 1391
Joined: Wed Mar 10, 2004 12:28 am


Return to QNX6 - OS

Who is online

Users browsing this forum: Exabot [Bot] and 3 guests