Skip navigation.
Home
The QNX Community Portal

View topic - QNX/QT application without Photon Fonts

QNX/QT application without Photon Fonts

Discussion about the general applications that run on QNX6

QNX/QT application without Photon Fonts

Postby pvazharov » Mon Jun 24, 2013 10:24 pm

Hi,

I've a task to port an existing QT application of our company to a Harman device running on QNX. I'm still new to QT and to QNX so I decided to create simple QT application first. I managed to create and run such application on VirtualBox hosted QNX x86. I still fails to run this application build for armle-v7 on the above device. The problem is that the OS on the device doesn't have anything related to photon - no ph, no phfont, etc. When I start the QT application on the divce it says - "QFontDatabase: Cannot find font directory /usr/photon/font_repository - is Qt installed correctly?". I see that there is no /usr/photon and of course no /usr/photon/font_repository at all. I probably could create the needed folder and set needed fonts inside, but this seems to me a little hacky? There should be another way for setting the needed fonts of this QT application?

I know that the root of the problem is that the Harman is modified too much the OS, but I can't change this fact.

Any help is highly appreciated.

Thanks in advance.
pvazharov
New Member
 
Posts: 8
Joined: Wed Jun 19, 2013 9:18 pm

Return to QNX6 - Applications

Who is online

Users browsing this forum: No registered users and 1 guest

cron