Skip navigation.
Home
The QNX Community Portal

View topic - Qt 4.7 build for QNX4.25

Qt 4.7 build for QNX4.25

For the old QNX2 and QNX4 RTOS

Qt 4.7 build for QNX4.25

Postby lullaby » Mon Nov 24, 2014 12:37 pm

Dear all,

As mentioned in earlier post by maschoen, I am trying to build Qt 4.7 for QNX4.25 referring the post:
http://community.qnx.com/sf/discussion/ ... _pagenum=1

I am using a Ubuntu Linux machine for building Qt 4.7 for QNX4.25 using the same command mentioned in the above link.
But during configure command, I got the following error.
./configure: line 6866: ntox86-g++-4.2.4: command not found

I understood that the QNX toolchain is not with me. My Momentics IDE installation has only toolchain folder for win32.
Where can I download the ntox86 toolchain for Linux?

Can anyone figure out the exact steps for building Qt for QNX4.25?

Thanks,
Lullaby
lullaby
Active Member
 
Posts: 82
Joined: Fri Jun 15, 2012 6:19 am

Re: Qt 4.7 build for QNX4.25

Postby Thunderblade » Mon Nov 24, 2014 2:54 pm

Hey... interesting topic. Why would someone try and use Qt 4.x on QNX 4.25? What can Qt 4.x do that Photon 1.14 couldn't?

lullaby wrote:As mentioned in earlier post by maschoen, I am trying to build Qt 4.7 for QNX4.25 referring the post:
http://community.qnx.com/sf/discussion/ ... _pagenum=1

I don't think the original poster really meant QNX4. He writes "QNX 4.5" and probably meant "QNX 6.5"- just a typo.

I am using a Ubuntu Linux machine for building Qt 4.7 for QNX4.25 using the same command mentioned in the above link.

This isn't going to work. You cannot build *anything* for QNX 4.25 on a Linux machine. This would require a toolset on Linux that supports building QNX 4.25 executeables. This doesn't exist and never will. QNX 4.25 was an OS on its own - when it was released no one was thinking about building QNX 4 executeables on a *different* OS. QNX started supporting a cross-development approach with QNX 6.1, AFAIR.

If you want to build anything for QNX 4.25, you have to do it *on* a QNX 4.25 machine. If you are not experienced in porting open source stuff to QNX 4.25, you won't succeed with something as huge as Qt. (and btw. why Qt 4.7 and not 4.8...)

You either should seek expert help, either from QNX, or from SWD (specialized QNX4 service provider) or from KDAB (Qt experts). Or you use QNX 6 and just take what's provided: Qt 5.3 pre-built.
Thunderblade
Senior Member
 
Posts: 487
Joined: Thu Apr 07, 2005 11:52 am

Re: Qt 4.7 build for QNX4.25

Postby lullaby » Tue Nov 25, 2014 6:01 am

Dear all,

Thank you, ThunderBlade for that valuable information.
I didn't recognize the QNX version in http://community.qnx.com/sf/discussion/ ... _pagenum=1
as a typo. :(

But I have seen another link: http://www.jcmichot.usenet-fr.net/QnXFree86/
where a person has already ported a much earlier version of Qt to QNX4.

I have downloaded it, but I found the version of Qt is Qt1.42. I am pretty sure that there won't be any webkit in this code...
Our actual feasibility is to get QtWebkit running on QNX4.25.
I found that QtWebkit source is integrated into Qt source code Qt4.6 only.(QtWebkit2.0)

Does anyone know whoever person in this world has ported Qt4.6 or any later version to QNX4.25?
I clearly understood that Qt can be easily ported to Neutrino.. But we can't upgrade our existing system..... :(

Looking forward to your replies...
Thanking you,
Lullaby.
lullaby
Active Member
 
Posts: 82
Joined: Fri Jun 15, 2012 6:19 am


Return to QNX2 and QNX4

Who is online

Users browsing this forum: No registered users and 4 guests