Skip navigation.
Home
The QNX Community Portal

View topic - QNX 6.6 Beaglebone Black spi

QNX 6.6 Beaglebone Black spi

For discussion of realtime and/or embedded programming.

QNX 6.6 Beaglebone Black spi

Postby dave909 » Fri Sep 23, 2016 12:42 am

Hi everyone,

I'm very new to QNX, and I am learning quickly, however the learning curve is very steep ( much like with any new microprocessor I guess) so hopefully I wont get shot down! :mrgreen:

I have 6.6 running on the Beaglebone Black, and so far I have all the peripherals I need working ( i2c, uart, gpio ) However I am a bit stuck getting SPI to work.

My project I have included hw/spi-master.h, however when i try to call any of the spi functions ( spi_open, etc) Momentics gives me a 'undefined reference to' error.

I have spi-master and pin mux set in the bsp, and HDMI has been disabled, but I think I am missing something else by the look of it. There seem to a be a few other threads here, but searching the forum turns up no real answers.

Maybe someone here has had success getting spi ( spi1 in particular ) going with BBB ?

Cheers

Dave
dave909
New Member
 
Posts: 2
Joined: Thu Sep 22, 2016 2:48 pm

Re: QNX 6.6 Beaglebone Black spi

Postby nico04 » Fri Sep 23, 2016 7:06 am

Have you added the SPI library to your Momentics project ?
nico04
Active Member
 
Posts: 77
Joined: Wed Sep 29, 2010 9:59 am
Location: France

Re: QNX 6.6 Beaglebone Black spi

Postby dave909 » Fri Sep 23, 2016 11:56 am

maybe :roll:

I think its fixed :)
dave909
New Member
 
Posts: 2
Joined: Thu Sep 22, 2016 2:48 pm

Re: QNX 6.6 Beaglebone Black spi

Postby nico04 » Fri Sep 23, 2016 1:16 pm

Great ! :lol:
nico04
Active Member
 
Posts: 77
Joined: Wed Sep 29, 2010 9:59 am
Location: France


Return to Realtime and Embedded

Who is online

Users browsing this forum: Google Adsense [Bot], Majestic-12 [Bot] and 3 guests