搜索找到 149 个匹配

power_du
周五 1月 14, 2005 8:16 am
版面: 四海同心QNX论坛
主题: xtang,请教一个6.1升级到6.2photon无法启动的问题
回复总数: 5
阅读次数: 2099

问题已解决

之前一直怀疑是io-graphics的问题,因为运行它之后就黑屏,经过多次试验发现,原来是font server的问题,在拷贝了需要的一些共享库文件后,photon环境恢复了正常启动。而这些共享库在6.1中是不需要的

经验总结:没有非常仔细的看帮助,最后还是在它的指导下完成配置的,惭愧啊惭愧
power_du
周一 1月 10, 2005 5:16 pm
版面: 四海同心QNX论坛
主题: xtang,请教一个6.1升级到6.2photon无法启动的问题
回复总数: 5
阅读次数: 2099

又做了试验:运行到photon环境需要三步:
运行photon:Photon
运行字体服务器:phfontFA -d/phembed/font_repository
运行显卡驱动:io-graphics -g640x480x16 -dldevg-geode.so -d0x1078,0x104 -I0 -R60

发现在运行显卡驱动后,黑屏,同时通过另一台机查看装置进程,发现phfontFA也同时退出了,只剩下Photon进程,真是郁闷,请大侠指教啊!!!
power_du
周一 1月 10, 2005 11:10 am
版面: 四海同心QNX论坛
主题: 请教:找不到网卡是什么原因?
回复总数: 4
阅读次数: 2188

xtang,问题已经解决,发现是因为第一张光盘没有完全安装的原因,把第一张盘全部安装后,问题解决
多谢了
power_du
周一 1月 10, 2005 8:08 am
版面: 四海同心QNX论坛
主题: xtang,请教一个6.1升级到6.2photon无法启动的问题
回复总数: 5
阅读次数: 2099

xtang先生,我昨天试过了这个方法,当“crttrap trap”后,系统提示:
/usr/photon/bin/devgt-iographics -dldevg-geode.so -d0x1078,0x104 -I0
memory fault
不知道为什么出现了内存错误?
我估计可能是这个原因导致不能正确驱动的?
请指教
power_du
周日 1月 09, 2005 2:35 pm
版面: 四海同心QNX论坛
主题: xtang,请教一个6.1升级到6.2photon无法启动的问题
回复总数: 5
阅读次数: 2099

经过一整天的试验,发现确实是io-graphics的问题,只要运行到它,就会黑屏。我又试了试devg-vesabiso.so,还是黑屏,真是奇怪。
后来我干脆在128M的cf卡上装了一个qnx6.21,它倒是可以正常的启动photon,但是我用从它上面看到的pidin ar结果来驱动,还是不行。
xtang,救急啊,多谢了
power_du
周六 1月 08, 2005 11:15 am
版面: 四海同心QNX论坛
主题: xtang,请教一个6.1升级到6.2photon无法启动的问题
回复总数: 5
阅读次数: 2099

xtang,请教一个6.1升级到6.2photon无法启动的问题

我最近想把装置从6.1的内核升级到6.2,以前6.1下配置一切正常能够正常启动我编写的phab程序,但是当我把.boot文件升级到6.2,并且升级了所有的.so文件和可执行文件后,发现无法启动phab程序。 我以前的图形驱动是用的,devg-cyrix.so,在6.2上已经没有了这个驱动,但有相应的升级驱动:devg-geode.so。在我使用新的驱动后,发现io-graphics无法启动,所以只好还是使用原来的devg-cyrix.so驱动。启动后在进程中可以查看到photon,phFontFA,io-graphcis都已经启动起来了,但是我下面试验运行的phcalc计算器没有启动,屏幕并且...
power_du
周五 1月 07, 2005 9:26 am
版面: 四海同心QNX论坛
主题: 请教:找不到网卡是什么原因?
回复总数: 4
阅读次数: 2188

xtang,pci-bios已经启动了
power_du
周四 1月 06, 2005 3:24 pm
版面: 四海同心QNX论坛
主题: 请教:找不到网卡是什么原因?
回复总数: 4
阅读次数: 2188

请教:找不到网卡是什么原因?

在硬盘上安装qnx6.2后,重新启动后有提示
can't mout / (type io-net)
mount possible reason:operation now in progress

启动完成后,找不到网卡,做如下处理
slay io-net
io-net -drtl -ptcpip -pqnet

还是找不到网卡,这到底是为什么呢?
该块cpu板如果是从cf卡启动,网卡是能驱动起来的,方法和上面列的一样,只不过驱动的运行是写在了.bld文件中

为什么会有这样的不同呢?请大侠赐教,多谢多谢
power_du
周四 1月 06, 2005 3:04 pm
版面: 四海同心QNX论坛
主题: 请教xtang,电脑为什么不能使用phditto访问我们的装置?
回复总数: 4
阅读次数: 1932

liug,装置上的photon环境已经设置好了,我可以在上面运行phab编写的程序,发生的错误我感觉像是以太网通信有问题,connet 装置不成功,装置端已经运行了phrelay,是不是phrelay需要某些特殊的配置或者动态库,但是就是不能成功,请大侠指教!!!
power_du
周三 1月 05, 2005 9:51 am
版面: 四海同心QNX论坛
主题: 请教xtang,电脑为什么不能使用phditto访问我们的装置?
回复总数: 4
阅读次数: 1932

请教xtang,电脑为什么不能使用phditto访问我们的装置?

装置上可以通过phditto访问电脑的photon,但是反过来就不行。

我是这样配置的:
装置上配置了inetd.conf和serviecs两个配置文件,启动ined


从电脑上通过phditto连接装置,shell提示如下:
。。。。
preload font cache
preload image cache
send connect
就停止了,提示error 19 [no such device]

请xtang,这是什么原因呢?难道必须要电脑和装置所有的硬件配置一样才能用phditto吗?
power_du
周五 9月 10, 2004 8:50 am
版面: 四海同心QNX论坛
主题: qde为什么这么脆弱?
回复总数: 1
阅读次数: 1303

qde为什么这么脆弱?

qde为什么这么脆弱?
我的qde才用了没多久,就突然启动不起来了,提示在加载resource.eclipse.org的库时遇到问题,怎么解决啊?难道只能重装吗?
power_du
周五 9月 10, 2004 8:29 am
版面: 四海同心QNX论坛
主题: wsforever你的usb存储驱动在6.2.1下用起来了吗?
回复总数: 9
阅读次数: 2827

多多交流

好的,本来想把我的license告诉你,可是发现已经过期了,呵呵
power_du
周三 9月 08, 2004 11:18 am
版面: 四海同心QNX论坛
主题: wsforever你的usb存储驱动在6.2.1下用起来了吗?
回复总数: 9
阅读次数: 2827

wsforever你的usb存储驱动在6.2.1下用起来了吗?

我也想在qnx下使用usb存储设备,不过我的也是6.2.1的版本,看到你在www.openqnx.com上的帖子,不知道你成功了没有,如果成功了,能把你的经验分享一下吗?

多谢了
power_du
周四 8月 12, 2004 9:56 am
版面: 四海同心QNX论坛
主题: vmware下的qnx在没有网络连接时如何与本机windows通信
回复总数: 0
阅读次数: 1905

vmware下的qnx在没有网络连接时如何与本机windows通信

1.首先把vmware上的网卡设置为hostonly模式 2.察看vmware的虚拟网卡VMnet1,这是用于hostonly模式的虚拟网卡,VMnet8是用于NAT模式的虚拟网卡。把vmnet1的ip设置为192.168.0.1 3.vmware下运行qnx,把ip设置为192.168.0.2,网关设为192.168.0.1 4.在windows下开个共享目录,命名为qnx.如果机器名为ibmer,用户名为administrator,密码为a,在qnx下打算mount到/tmp目录,运行如下命令: fs-cifs //ibmer:192.168.0.1:/qnx /tmp administr...
power_du
周日 5月 09, 2004 7:30 pm
版面: 四海同心QNX论坛
主题: qnx中为什么不能用mkifs
回复总数: 5
阅读次数: 3087

换个版本吧

用qnx 6.1 nc版就有