[新手问题]qnx 声卡驱动安装

中文QNX 讨论: 欢迎大家灌水,讨论有关QNX 问题。
回复
heavenflames
New Member
帖子: 4
注册时间: 周二 6月 07, 2011 3:06 am

[新手问题]qnx 声卡驱动安装

帖子 heavenflames » 周二 6月 07, 2011 3:13 am

我是新手,初来乍到,大家好!

THINKPAD W500的本子, 刚装的QNX6.5
pci的audio信息是
Vendor ID = 8086h, Intel Corporation
Device ID = 293eh, 82801I (ICH9 Family) HD Audio Controller
PCI index = 0h
Class Codes = 040300h
Revision ID = 3h
Bus number = 0
Device number = 27
Function num = 0
Status Reg = 10h
Command Reg = 106h

/lib/dll里面的确是有deva-ctril-intel_hda.so

但是
io-audio
mount -Tio-audio /lib/dll/deva-ctrl-intel_hda.so 结果是
mount: Can't mount / (type io-audio)
mount: POssible reason: Program version wrong..

这是个啥问题,大家能帮忙看看么。

heavenflames
New Member
帖子: 4
注册时间: 周二 6月 07, 2011 3:06 am

Re: [新手问题]qnx 声卡驱动安装

帖子 heavenflames » 周二 6月 07, 2011 3:17 am

下载了最新的deva-ctrl-intel_hda.so
io-audio
mount -Tio-audio /lib/dll/deva-ctrl-intel_hda.so 结果变成
mount: Can't mount / (type io-audio)
mount: Possible reason: Invalid argument


heavenflames 写了:我是新手,初来乍到,大家好!

THINKPAD W500的本子, 刚装的QNX6.5
pci的audio信息是
Vendor ID = 8086h, Intel Corporation
Device ID = 293eh, 82801I (ICH9 Family) HD Audio Controller
PCI index = 0h
Class Codes = 040300h
Revision ID = 3h
Bus number = 0
Device number = 27
Function num = 0
Status Reg = 10h
Command Reg = 106h

/lib/dll里面的确是有deva-ctril-intel_hda.so

但是
io-audio
mount -Tio-audio /lib/dll/deva-ctrl-intel_hda.so 结果是
mount: Can't mount / (type io-audio)
mount: POssible reason: Program version wrong..

这是个啥问题,大家能帮忙看看么。

heavenflames
New Member
帖子: 4
注册时间: 周二 6月 07, 2011 3:06 am

Re: [新手问题]qnx 声卡驱动安装

帖子 heavenflames » 周三 6月 08, 2011 12:50 am

anybody...please help....

driven crazy by this...

many thanks!
heavenflames 写了:我是新手,初来乍到,大家好!

THINKPAD W500的本子, 刚装的QNX6.5
pci的audio信息是
Vendor ID = 8086h, Intel Corporation
Device ID = 293eh, 82801I (ICH9 Family) HD Audio Controller
PCI index = 0h
Class Codes = 040300h
Revision ID = 3h
Bus number = 0
Device number = 27
Function num = 0
Status Reg = 10h
Command Reg = 106h

/lib/dll里面的确是有deva-ctril-intel_hda.so

但是
io-audio
mount -Tio-audio /lib/dll/deva-ctrl-intel_hda.so 结果是
mount: Can't mount / (type io-audio)
mount: POssible reason: Program version wrong..

这是个啥问题,大家能帮忙看看么。

xtang
Moderator
帖子: 1816
注册时间: 周五 9月 12, 2003 4:14 am
来自: China

帖子 xtang » 周一 6月 13, 2011 3:53 pm

也许你已经检查过了...

在标准开机时,系统自检会自己启动io-audio,如果不把系统启动的io-audio停掉的话,再启新的io-audio是没有用的。

你可以看看你的系统里是不是已经有io-audio在执行了?(pidin -p io-audio)
如果有要把原来的io-audio先停掉 (slay io-audio)

heavenflames
New Member
帖子: 4
注册时间: 周二 6月 07, 2011 3:06 am

帖子 heavenflames » 周四 6月 16, 2011 4:38 am

多谢xtang, 但是根本没有io-audio 在运行。。。


xtang 写了:也许你已经检查过了...

在标准开机时,系统自检会自己启动io-audio,如果不把系统启动的io-audio停掉的话,再启新的io-audio是没有用的。

你可以看看你的系统里是不是已经有io-audio在执行了?(pidin -p io-audio)
如果有要把原来的io-audio先停掉 (slay io-audio)

回复