新手求助:定制PHOTON映像时碰到FONT问题

中文QNX 讨论: 欢迎大家灌水,讨论有关QNX 问题。
回复
tiancw
New Member
帖子: 7
注册时间: 周一 9月 05, 2011 9:54 am

新手求助:定制PHOTON映像时碰到FONT问题

帖子 tiancw » 周一 9月 05, 2011 10:12 am

各位高手好:本人在做带有图形界面的QNX系统时,启动之后老是提示“Unable to attach to font server,pf_attach():No Such file or directory”,不知是缺什么动态库还是其它原因,请高手赐教,非常感谢! :lol:

机器人
Senior Member
帖子: 106
注册时间: 周二 4月 27, 2010 12:09 pm
来自: 中国

Re: 新手求助:定制PHOTON映像时碰到FONT问题

帖子 机器人 » 周一 9月 05, 2011 10:31 am

可以启动phfont试试看。

tiancw
New Member
帖子: 7
注册时间: 周一 9月 05, 2011 9:54 am

Re: 新手求助:定制PHOTON映像时碰到FONT问题

帖子 tiancw » 周一 9月 05, 2011 10:49 am

谢谢您的赐教,我稍后试一下。另外,我一直有个疑问,如果在映像中添加了所有动态连接库和执行文件,除了COPY IFS, 是不是不用拷贝任何目录到目标机?

机器人
Senior Member
帖子: 106
注册时间: 周二 4月 27, 2010 12:09 pm
来自: 中国

Re: 新手求助:定制PHOTON映像时碰到FONT问题

帖子 机器人 » 周一 9月 05, 2011 2:53 pm

不需要的

tiancw
New Member
帖子: 7
注册时间: 周一 9月 05, 2011 9:54 am

Re: 新手求助:定制PHOTON映像时碰到FONT问题

帖子 tiancw » 周二 9月 06, 2011 8:14 am

感谢您的回复,我的phfont已经正常运行,现在的情况是:PHOTON已进入,能看到鼠标,而且可以动,就是屏幕全是黑的,请问这是缺什么文件?是不是没有默认用户啊?如何建用户?非常感谢!

机器人
Senior Member
帖子: 106
注册时间: 周二 4月 27, 2010 12:09 pm
来自: 中国

Re: 新手求助:定制PHOTON映像时碰到FONT问题

帖子 机器人 » 周三 9月 07, 2011 11:09 am

表示你的Photon已经启动好了,

黑屏 只是你没有启动背景,和其他程序

tiancw
New Member
帖子: 7
注册时间: 周一 9月 05, 2011 9:54 am

Re: 新手求助:定制PHOTON映像时碰到FONT问题

帖子 tiancw » 周五 9月 09, 2011 8:39 am

非常感谢您的答复,我的PHOTON现在已能正常显示图形界面。不过与PHOTON相关的文件和目录我是直接拷贝到硬盘的,总共大概有180M。如果完全自己一个一个添加到IMAGE,感觉要添好多东西,我这的版本是6.5,您那有PHOTON的完整IMAGE文件吗?如有能发给我一份做下参考吗?我的邮箱是:tian_cw@hotmail.com。无论怎样我都非常感谢您的热心回复。

Thanks a lot!
Goog luck!

回复