6.2下编译的程序能在6.1下运行吗?

中文QNX 讨论: 欢迎大家灌水,讨论有关QNX 问题。
回复
power_du
Senior Member
帖子: 149
注册时间: 周五 9月 12, 2003 4:37 am

6.2下编译的程序能在6.1下运行吗?

帖子 power_du » 周二 2月 01, 2005 5:16 pm

执行时提示:
unknown symbol: warnx
unknown symbol: err
unknown symbol: syslog
unknown symbol: warn
Could not resolve all symbols

这是什么原因啊,如何解决?

xtang
Moderator
帖子: 1816
注册时间: 周五 9月 12, 2003 4:14 am
来自: China

帖子 xtang » 周三 2月 02, 2005 5:35 am

可以试试静态链接,在链接的时候加 -Bstatic

power_du
Senior Member
帖子: 149
注册时间: 周五 9月 12, 2003 4:37 am

帖子 power_du » 周三 2月 02, 2005 8:58 am

唐先生,我是在windows下的IDE开发的,如何把链接参数加上呢?

power_du
Senior Member
帖子: 149
注册时间: 周五 9月 12, 2003 4:37 am

帖子 power_du » 周三 2月 02, 2005 9:31 am

加上了还是不行,我如果想在6.2的IDE下生成6。1能运行的程序,应该如何设置呢?

power_du
Senior Member
帖子: 149
注册时间: 周五 9月 12, 2003 4:37 am

帖子 power_du » 周三 2月 02, 2005 2:54 pm

唐先生,请教一下,如何能在6.21的windows IDE下生成6.1能运行的程序呢?上面提到的问题在6.1下编译就没有问题了

多谢指教!

回复