网络——关于集成网卡RT8169

中文QNX 讨论: 欢迎大家灌水,讨论有关QNX 问题。
回复
qiming_ni
Senior Member
帖子: 43
注册时间: 周日 6月 17, 2007 7:37 am
来自: 2.2.2.2
联系:

网络——关于集成网卡RT8169

帖子 qiming_ni » 周三 7月 04, 2007 8:37 pm

由于QNX6.2.1不支持网卡RT8169,所以我在开机后,用了如下的命令进行设置:

slay io-net
io-net -d speedo vid=0x0x10ec,did=0x8167 verbose -ptcpip
inetd

在PH下面的network配置页面中可以看到网卡被识别了,然后我就设置IP地址:192.168.0.200,掩码:255.255.255.0,Default Gatway:192.168.0.1,DNS server:192.168.0.1。

在Terminal中ping 192.168.0.200可以,但是ping别的机子都不行,不知道问题出在什么地方?
sdf

liug
Moderator
帖子: 130
注册时间: 周五 9月 12, 2003 4:14 am
来自: 美国 加州

帖子 liug » 周四 7月 05, 2007 11:59 pm


qiming_ni
Senior Member
帖子: 43
注册时间: 周日 6月 17, 2007 7:37 am
来自: 2.2.2.2
联系:

帖子 qiming_ni » 周五 7月 06, 2007 10:57 am

但我的问题是网卡可以识别出来,可仍然没法用!跟ningmengqzh一样的网卡RTL8169,却出现不同的问题,我不知道为什么?

而且,我用“pci -v"指令时,network的厂家是RealTek,但是用"nicinfo"时却显示是Intel的,它的显示信息如下:

INTEL 82557 Ethernet Controller
Physical Node ID..............................FFFFFF FFFFFF
Current Physical Node ID..................FFFFFF FFFFFF
Current Operation Rate.....................Unknow
Active Interface Type........................UTP
Maximum Transmittable data Unit.......1514
Maximum Receivable data Unit...........1514
Hardware Interrupt............................0xa
I/O Aperture.....................................0xe1000000-0xe10000ff
Memory Aperture..............................0xa000-0xa0ff
Promisuous Mode..............................Off
Multicast Support..............................Enabled
get states: Input/Output error

我在用"ifconfig"的指令时发现address的值是FF FF FF FF FF FF,设置的IP地址和掩码都可以正确显示出来。

是不是我这个RTL8169就是不能用啊?????????????

另外,我也考虑过可能我的加载指令
"io-net -d speedo vid=0x0x10ec,did=0x8167 verbose -ptcpip "
有问题,应该是
"# io-net -d rtl vid=0x10ec,did=0x8169 -ptcpip ",但是试过之后,系统显示没有devn-rtl.so这个驱动,有没有可能是我的QNX系统有问题??但是我在两台机子上一个是QNX6.2.1,另一台装的是QNX6.3.2,却出现同样的问题!很迷惘啊!

liug
Moderator
帖子: 130
注册时间: 周五 9月 12, 2003 4:14 am
来自: 美国 加州

帖子 liug » 周五 7月 06, 2007 12:10 pm

我的QNX6.21有

/lib/dll/devn-rtl.so

说明书: http://www.openqnx.com/static/neutrino/ ... tl.so.html

回复