How do I get pc line drawing characters to show up in qtalk?

bridged with qdn.public.qnxrtp.newuser
John Eddy

Re: How do I get pc line drawing characters to show up in qt

Post by John Eddy » Mon Jun 23, 2003 11:54 am

I had actually throught about doing it in photon, or writing a translation
routine, but by now I don't think they will let me charge anymore time to
this minor issue.

I did find a version of hyperterm on the hillgrave (original maker of
hyperterm) site. Hyperterm Private Edition is a free download for
non-commercial use. As far as I can tell, it doesn't do much more than allow
you to adjust the number of rows and columns compared to the standard
windows version. It looks to me like the version they allow windows to
incorporate is intentionally limited so people have to go to them for an
"upgrade". I swear I remember seeing that option to change the rows and
columns in an earlier verion of windows, I just can't remember which one it
was.

Thanks,

John Eddy

"Wojtek Lerch" <wojtek_l@yahoo.ca> wrote in message
news:bcsnnm$6ib$1@inn.qnx.com...
John Eddy <john.h.eddy@lmco.com> wrote:
Ok, I tried opening pterm with -Q and running qtalk in it with the bios
screen being updated... It was worse than opening things the default
way.

The bios is outputting ANSI commands to move to the beginning of a line
before it outputs the characters on that line. These escape sequences
are
not translated right when I use -Q. I can't tell if the line drawing
characters are there or not, because everything gets underlined and
bolded,
and scrolls down the page rapidly (updates at 115200 bps).

Ah. So your BIOS assumes that the terminal it talks to understands ANSI
escape sequences but maps all of the upper 128 character codes to the PC
character set. Sorry, I'm afraid we don't have a terminal emulator that
does both.

The line drawing characters look good and even the colors look right
when I
use hyperterm to view this bios output, but I get jumping due to the
fact
that it is outputting 80 X 25 and hyperterm only handles 24 lines. Also,
I
don't really want to have to run in windows.

I don't get the scrolling/jumping in qtalk, but the line drawing and the
colors are gone. I was just hoping there was a quick fix for this, but
it is
getting way too involved. I don't want to have to define my own font, or
write my own terminal program just to see the line drawing characters. I
just wanted to know how to set up qtalk or some other already existing
terminal program to see the characters correctly.

This has nothing to do with qtalk: qtalk just reads bytes from the
serial port and writes them to the terminal. You don't even really need
qtalk -- you could run pterm directly on the serial port with a very
similar result (pterm -d /dev/ser1). It's pterm that interprets the
bytes you write to the terminal and decides which ones are control
characters and which ones should be displayed in Photon and which
Unicode values to map them to when they're displayed.

You *could* try to insert a program between the serial port and pterm
(using a pipe and pterm's -D option), and translate bytes above 128 to
ANSI linedrawing escape sequences in that program. Or, even better, you
could write it as a Photon program with a PtTty widget in it, and do the
translation in the Pt_CB_TTY_OUTPUT callback. It would be much simpler
than writing your own terminal program from scratch...

Post Reply

Return to “qdn.public.qnxrtp.newuser”