Remote time setting.

bridged with qdn.public.qnxrtp.os
Post Reply
Benjamin Rogers

Remote time setting.

Post by Benjamin Rogers » Wed Oct 04, 2000 2:44 am

We have problem in which the hardware we are using doesn't have the correct
time each time we cold reboot.
This is due to not having a bios battery in order to save time.

Therefore I am looking for a way in which to update the time on start-up. I
was surprised to find not such util.

I looked at the function rtc and the ' use ' command and it described the
ability to do:
' rtc net <node>' but I can't seem to get it to work.

In the QRTP documentation it doesn't mention the net command. Is there a
version problem here?

Cheers Ben.

Steve Reid

Re: Remote time setting.

Post by Steve Reid » Wed Oct 04, 2000 2:04 pm

Benjamin Rogers <brogers@nospam.patrick.com.au> wrote:
: We have problem in which the hardware we are using doesn't have the correct
: time each time we cold reboot.
: This is due to not having a bios battery in order to save time.

: Therefore I am looking for a way in which to update the time on start-up. I
: was surprised to find not such util.

: I looked at the function rtc and the ' use ' command and it described the
: ability to do:
: ' rtc net <node>' but I can't seem to get it to work.

: In the QRTP documentation it doesn't mention the net command. Is there a
: version problem here?

My comments in the docs state that "net" isn't implemented. It sounds like
it really isn't, no matter what the usage message says.

------------------------------------------
Steve Reid stever@qnx.com
TechPubs (Technical Publications)
QNX Software Systems Ltd.
------------------------------------------

Colin Burgess

Re: Remote time setting.

Post by Colin Burgess » Wed Oct 04, 2000 2:24 pm

I've added a pr for rtc.

In the meantime, you could use something like rdate, as long as
the remote machine is running inetd.

It's in the netbsd utils, and ports pretty easily.

You can get a binary at http://staff.qnx.com/~cburgess/rdate

Steve Reid <stever@qnx.com> wrote:
Benjamin Rogers <brogers@nospam.patrick.com.au> wrote:
: We have problem in which the hardware we are using doesn't have the correct
: time each time we cold reboot.
: This is due to not having a bios battery in order to save time.

: Therefore I am looking for a way in which to update the time on start-up. I
: was surprised to find not such util.

: I looked at the function rtc and the ' use ' command and it described the
: ability to do:
: ' rtc net <node>' but I can't seem to get it to work.

: In the QRTP documentation it doesn't mention the net command. Is there a
: version problem here?

My comments in the docs state that "net" isn't implemented. It sounds like
it really isn't, no matter what the usage message says.

------------------------------------------
Steve Reid stever@qnx.com
TechPubs (Technical Publications)
QNX Software Systems Ltd.
------------------------------------------
--
cburgess@qnx.com

Post Reply

Return to “qdn.public.qnxrtp.os”