IDE hangs on debug

bridged with qdn.public.qnxrtp.devtools
Post Reply
Steve

IDE hangs on debug

Post by Steve » Thu Dec 12, 2002 11:55 am

I have a debug build of some code that I'm trying to run on a remote target
from the IDE. I get the following message and then the IDE hangs. I have to
quit the IDE. The release build works fine by transfering to the target and
executing from command line.
Other simple .cpp programs also work via remote debug from the IDE, this
build is more complex but doesn't include any specific QNX calls ie. no
multithreading, just generic cpp and compiles with no warnings.

any ideas on how to debug the debugger ??

MsgNak received - resending

* 1 process 1843229 (state = 0x03)

Steve

Re: IDE hangs on debug

Post by Steve » Thu Dec 12, 2002 4:43 pm

If I copy file_g to the remote machine I can telnet to the remote machine
and run the file_g from gdb on the command line. I can then step over and
into the file as expected.

If gdb from command line can do this why can't the IDE do the same, I'm
using the same execuatble in both cases. An IDE bug ??




"Steve" <stevec@nav-tech.com> wrote in message
news:at9su8$bpl$1@inn.qnx.com...
I have a debug build of some code that I'm trying to run on a remote
target
from the IDE. I get the following message and then the IDE hangs. I have
to
quit the IDE. The release build works fine by transfering to the target
and
executing from command line.
Other simple .cpp programs also work via remote debug from the IDE, this
build is more complex but doesn't include any specific QNX calls ie. no
multithreading, just generic cpp and compiles with no warnings.

any ideas on how to debug the debugger ??

MsgNak received - resending

* 1 process 1843229 (state = 0x03)



Post Reply

Return to “qdn.public.qnxrtp.devtools”