SciTE for qnx6.2 available at openqnx

bridged with qdn.public.qnxrtp.devtools
Post Reply
Armin Steinhoff

SciTE for qnx6.2 available at openqnx

Post by Armin Steinhoff » Tue Dec 17, 2002 10:19 pm

GTK++ based ... just better than NEdit :)

>>>Armin

Armin

Re: SciTE for qnx6.2 available at openqnx

Post by Armin » Sat Dec 21, 2002 5:02 pm

Armin Steinhoff wrote:
GTK+ based ... just better than NEdit :)
SciTE -> http://www.scintilla.org/SciTE.html

SciTE allows to export source code as HTML, RTF. LaTex.

The tool menu works like a comfortable tiny IDE.
(click on err msg of the compiler ... jumps to the
appropriate source code line)

Syntax coloring for a bunch of programming languages.
Encoding 8bit, USC-2, UTF-8 ... good keyboard support.
Display option for end-of-line characters ....

Important settings in SciTEGlobal.properties:

# initial editor window
if PLAT_GTK
position.left=0
position.top=0
position.width=1135
position.height=970

# end-of-line char = LF
eol.mode=LF

My last 2 cents

Armin

Otto Mixa

Re: SciTE for qnx6.2 available at openqnx

Post by Otto Mixa » Thu Jan 02, 2003 3:36 pm

Armin wrote:
Armin Steinhoff wrote:

GTK+ based ... just better than NEdit :)


SciTE -> http://www.scintilla.org/SciTE.html

SciTE allows to export source code as HTML, RTF. LaTex.

The tool menu works like a comfortable tiny IDE.
(click on err msg of the compiler ... jumps to the
appropriate source code line)

Syntax coloring for a bunch of programming languages.
Encoding 8bit, USC-2, UTF-8 ... good keyboard support.
Display option for end-of-line characters ....

Important settings in SciTEGlobal.properties:

# initial editor window
if PLAT_GTK
position.left=0
position.top=0
position.width=1135
position.height=970

# end-of-line char = LF
eol.mode=LF

My last 2 cents

Armin
Hello,
I was downloaded Scite, in windows is working fine, but in QNX I've got
error message:
Could not find library libgdk-1.2.so.9
Please can somebody help me where I can find this library for QNX6.2NC?
Thanks a lot for all answers.

Armin Steinhoff

Re: SciTE for qnx6.2 available at openqnx

Post by Armin Steinhoff » Fri Jan 03, 2003 7:56 pm

Otto Mixa wrote:
Armin wrote:

Armin Steinhoff wrote:

GTK+ based ... just better than NEdit :)



SciTE -> http://www.scintilla.org/SciTE.html

SciTE allows to export source code as HTML, RTF. LaTex.

The tool menu works like a comfortable tiny IDE.
(click on err msg of the compiler ... jumps to the
appropriate source code line)

Syntax coloring for a bunch of programming languages.
Encoding 8bit, USC-2, UTF-8 ... good keyboard support.
Display option for end-of-line characters ....

Important settings in SciTEGlobal.properties:

# initial editor window
if PLAT_GTK
position.left=0
position.top=0
position.width=1135
position.height=970

# end-of-line char = LF
eol.mode=LF

My last 2 cents

Armin


Hello,
I was downloaded Scite, in windows is working fine, but in QNX I've got
error message:
Could not find library libgdk-1.2.so.9
Please can somebody help me where I can find this library for QNX6.2NC?
Thanks a lot for all answers.
Please install GTK+ from the 3th party CD ... or download and install
the gtk-glib-1.2.10 archive from http://www.sf.net/project/openqnx

Regards

Armin

Otto Mixa

Re: SciTE for qnx6.2 available at openqnx

Post by Otto Mixa » Mon Jan 06, 2003 12:05 pm

Thanks,but...
I have got already installed gtk-glib-1.2.10,sorry that i didn't mention
about that.So it seems that I have got compiled version of SciTe which
is required earlier version of gtk.Is it possible,and don't you know
where I can find executable app SciTe based on gtk-glib-1.2.10 ?
Thanks a lot.
Otto

Armin Steinhoff wrote:
Otto Mixa wrote:

Armin wrote:

Armin Steinhoff wrote:

GTK+ based ... just better than NEdit :)




SciTE -> http://www.scintilla.org/SciTE.html

SciTE allows to export source code as HTML, RTF. LaTex.

The tool menu works like a comfortable tiny IDE.
(click on err msg of the compiler ... jumps to the
appropriate source code line)

Syntax coloring for a bunch of programming languages.
Encoding 8bit, USC-2, UTF-8 ... good keyboard support.
Display option for end-of-line characters ....

Important settings in SciTEGlobal.properties:

# initial editor window
if PLAT_GTK
position.left=0
position.top=0
position.width=1135
position.height=970

# end-of-line char = LF
eol.mode=LF

My last 2 cents

Armin


Hello,
I was downloaded Scite, in windows is working fine, but in QNX I've
got error message:
Could not find library libgdk-1.2.so.9
Please can somebody help me where I can find this library for QNX6.2NC?
Thanks a lot for all answers.


Please install GTK+ from the 3th party CD ... or download and install
the gtk-glib-1.2.10 archive from http://www.sf.net/project/openqnx

Regards

Armin


liug

Re: SciTE for qnx6.2 available at openqnx

Post by liug » Mon Jan 06, 2003 5:13 pm

Looks like SciTE was compiled against the gtk/glib from the
3rd party CD. so you need to install them from there.
http://packages.qnx.com/contrib/reposit ... sitory.qrm
frank

Otto Mixa <ottomixa@email.cz> wrote:
Thanks,but...
I have got already installed gtk-glib-1.2.10,sorry that i didn't mention
about that.So it seems that I have got compiled version of SciTe which
is required earlier version of gtk.Is it possible,and don't you know
where I can find executable app SciTe based on gtk-glib-1.2.10 ?
Thanks a lot.
Otto

Armin Steinhoff wrote:
Otto Mixa wrote:

Armin wrote:

Armin Steinhoff wrote:

GTK+ based ... just better than NEdit :)




SciTE -> http://www.scintilla.org/SciTE.html

SciTE allows to export source code as HTML, RTF. LaTex.

The tool menu works like a comfortable tiny IDE.
(click on err msg of the compiler ... jumps to the
appropriate source code line)

Syntax coloring for a bunch of programming languages.
Encoding 8bit, USC-2, UTF-8 ... good keyboard support.
Display option for end-of-line characters ....

Important settings in SciTEGlobal.properties:

# initial editor window
if PLAT_GTK
position.left=0
position.top=0
position.width=1135
position.height=970

# end-of-line char = LF
eol.mode=LF

My last 2 cents

Armin


Hello,
I was downloaded Scite, in windows is working fine, but in QNX I've
got error message:
Could not find library libgdk-1.2.so.9
Please can somebody help me where I can find this library for QNX6.2NC?
Thanks a lot for all answers.


Please install GTK+ from the 3th party CD ... or download and install
the gtk-glib-1.2.10 archive from http://www.sf.net/project/openqnx

Regards

Armin


Armin

Re: SciTE for qnx6.2 available at openqnx

Post by Armin » Tue Jan 07, 2003 12:38 pm

liug wrote:
Looks like SciTE was compiled against the gtk/glib from the
3rd party CD.
Correct ... it was also compiled for SE/PE, so it looks like that
there are library differences between NC and SE/PE.

I will post the modified sources of SciTE at openqnx ... so everyone can
recompile it for NC.

Armin
so you need to install them from there.
http://packages.qnx.com/contrib/reposit ... sitory.qrm
frank

Otto Mixa <ottomixa@email.cz> wrote:

Thanks,but...
I have got already installed gtk-glib-1.2.10,sorry that i didn't mention
about that.So it seems that I have got compiled version of SciTe which
is required earlier version of gtk.Is it possible,and don't you know
where I can find executable app SciTe based on gtk-glib-1.2.10 ?
Thanks a lot.
Otto


Armin Steinhoff wrote:

Otto Mixa wrote:


Armin wrote:


Armin Steinhoff wrote:


GTK+ based ... just better than NEdit :)




SciTE -> http://www.scintilla.org/SciTE.html

SciTE allows to export source code as HTML, RTF. LaTex.

The tool menu works like a comfortable tiny IDE.
(click on err msg of the compiler ... jumps to the
appropriate source code line)

Syntax coloring for a bunch of programming languages.
Encoding 8bit, USC-2, UTF-8 ... good keyboard support.
Display option for end-of-line characters ....

Important settings in SciTEGlobal.properties:

# initial editor window
if PLAT_GTK
position.left=0
position.top=0
position.width=1135
position.height=970

# end-of-line char = LF
eol.mode=LF

My last 2 cents

Armin


Hello,
I was downloaded Scite, in windows is working fine, but in QNX I've
got error message:
Could not find library libgdk-1.2.so.9
Please can somebody help me where I can find this library for QNX6.2NC?
Thanks a lot for all answers.


Please install GTK+ from the 3th party CD ... or download and install
the gtk-glib-1.2.10 archive from http://www.sf.net/project/openqnx

Regards

Armin





Otto Mixa

Re: SciTE for qnx6.2 available at openqnx

Post by Otto Mixa » Tue Jan 07, 2003 1:50 pm

Thanks a lot.
Otto

Armin wrote:
liug wrote:

Looks like SciTE was compiled against the gtk/glib from the
3rd party CD.


Correct ... it was also compiled for SE/PE, so it looks like that
there are library differences between NC and SE/PE.

I will post the modified sources of SciTE at openqnx ... so everyone can
recompile it for NC.

Armin

so you need to install them from there.
http://packages.qnx.com/contrib/reposit ... sitory.qrm
frank

Otto Mixa <ottomixa@email.cz> wrote:

Thanks,but...
I have got already installed gtk-glib-1.2.10,sorry that i didn't
mention about that.So it seems that I have got compiled version of
SciTe which is required earlier version of gtk.Is it possible,and
don't you know where I can find executable app SciTe based on
gtk-glib-1.2.10 ?
Thanks a lot.
Otto



Armin Steinhoff wrote:

Otto Mixa wrote:


Armin wrote:


Armin Steinhoff wrote:


GTK+ based ... just better than NEdit :)





SciTE -> http://www.scintilla.org/SciTE.html

SciTE allows to export source code as HTML, RTF. LaTex.

The tool menu works like a comfortable tiny IDE.
(click on err msg of the compiler ... jumps to the
appropriate source code line)

Syntax coloring for a bunch of programming languages.
Encoding 8bit, USC-2, UTF-8 ... good keyboard support.
Display option for end-of-line characters ....

Important settings in SciTEGlobal.properties:

# initial editor window
if PLAT_GTK
position.left=0
position.top=0
position.width=1135
position.height=970

# end-of-line char = LF
eol.mode=LF

My last 2 cents

Armin


Hello,
I was downloaded Scite, in windows is working fine, but in QNX I've
got error message:
Could not find library libgdk-1.2.so.9
Please can somebody help me where I can find this library for
QNX6.2NC?
Thanks a lot for all answers.



Please install GTK+ from the 3th party CD ... or download and
install the gtk-glib-1.2.10 archive from
http://www.sf.net/project/openqnx

Regards

Armin






Chris McKillop

Re: SciTE for qnx6.2 available at openqnx

Post by Chris McKillop » Tue Jan 07, 2003 8:27 pm

Armin <a-steinhoff@web.de> wrote:
Looks like SciTE was compiled against the gtk/glib from the
3rd party CD.

Correct ... it was also compiled for SE/PE, so it looks like that
there are library differences between NC and SE/PE.

I will post the modified sources of SciTE at openqnx ... so everyone can
recompile it for NC.
I don't think so. The only thing I am aware of that is different is
that in SE/PE the default C++ environment is dinkum based and that
the dinkum C++ runtime lib didn't get shipped (by mistake) with NC for
6.2.0. All of the gtk apps on the 3rd Party CDROM where built on PE
and they all work perfectly on NC.

To me this sounds like user error.

chris

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Otto Mixa

Re: SciTE for qnx6.2 available at openqnx

Post by Otto Mixa » Wed Jan 08, 2003 10:33 am

Is the Dinkum libraries which wasn't released in NC also possible reason of
some unsatisfied packages?Because in those packages are dependencies on some
required libraries and I can't find them.

Otto

"Chris McKillop" <cdm@qnx.com> wrote in message
news:avfd73$dt8$1@nntp.qnx.com...
Armin <a-steinhoff@web.de> wrote:
Looks like SciTE was compiled against the gtk/glib from the
3rd party CD.

Correct ... it was also compiled for SE/PE, so it looks like that
there are library differences between NC and SE/PE.

I will post the modified sources of SciTE at openqnx ... so everyone can
recompile it for NC.


I don't think so. The only thing I am aware of that is different is
that in SE/PE the default C++ environment is dinkum based and that
the dinkum C++ runtime lib didn't get shipped (by mistake) with NC for
6.2.0. All of the gtk apps on the 3rd Party CDROM where built on PE
and they all work perfectly on NC.

To me this sounds like user error.

chris

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Chris McKillop

Re: SciTE for qnx6.2 available at openqnx

Post by Chris McKillop » Wed Jan 08, 2003 8:40 pm

Otto Mixa <ottomixa@email.cz> wrote:
Is the Dinkum libraries which wasn't released in NC also possible reason of
some unsatisfied packages?Because in those packages are dependencies on some
required libraries and I can't find them.
Possibly, if the app is C++ and wasn't linked with the GNU libs. You can just
symlink libcpp.so.2 to libcpp.so.2a and tell the installer to ignore the
dependancy.

chris

--
Chris McKillop <cdm@qnx.com> "The faster I go, the behinder I get."
Software Engineer, QSSL -- Lewis Carroll --
http://qnx.wox.org/

Armin Steinhoff

Re: SciTE for qnx6.2 available at openqnx

Post by Armin Steinhoff » Wed Jan 08, 2003 10:09 pm

Chris McKillop wrote:
Otto Mixa <ottomixa@email.cz> wrote:
Is the Dinkum libraries which wasn't released in NC also possible reason of
some unsatisfied packages?Because in those packages are dependencies on some
required libraries and I can't find them.


Possibly, if the app is C++ and wasn't linked with the GNU libs. You can just
symlink libcpp.so.2 to libcpp.so.2a and tell the installer to ignore the
dependancy.
... and this sounds still for you as a 'user error' ???
The problem _are_ the different libraries for NC and SE/PE !

The modified sources of scintilla and SciTE are available at openqnx.

Armin

Post Reply

Return to “qdn.public.qnxrtp.devtools”