packager won't pick up Script and Launch from *.qpg

bridged with qdn.public.qnxrtp.devtools
Post Reply
Guest

packager won't pick up Script and Launch from *.qpg

Post by Guest » Wed Jan 22, 2003 10:14 pm

I'm trying to make "packager" recognize the Launch Menu setups
in unattended mode, but whatever written in *.qpg
won't be picked up.

Tried <QPG:PackageFilter type="core"> etc etc but no banana.
(Strangely some other setups are picked up)

Do I have to manually answer the Launch spec every time?
--
kabe
package.qpg *excerpt* follows:

<QPG:Generation>
<QPG:Values>
<QPG:PackageFilter>
<QPM:PackageManifest>

<QPM:ProductInstallationProcedure xmlmultiple="true">

<QPM:Script xmlmultiple="true">
<QPM:ScriptName>/usr/photon/bin/launchmenu_notify</QPM:ScriptName>
<QPM:ScriptTiming>Post</QPM:ScriptTiming>
<QPM:ScriptType>Use</QPM:ScriptType>
</QPM:Script>

<QPM:Script xmlmultiple="true">
<QPM:ScriptName>/usr/photon/bin/launchmenu_notify</QPM:ScriptName>
<QPM:ScriptTiming>Post</QPM:ScriptTiming>
<QPM:ScriptType>Unuse</QPM:ScriptType>
</QPM:Script>
</QPM:ProductInstallationProcedure>
</QPM:PackageManifest>

<QPM:Launch name="mnews" xmlmultiple="true">
<QPM:String name="Topic" value="Application/Internet" xmlmultiple="true"/>
<QPM:String name="Command" value="pterm mnews" xmlmultiple="true"/>
<QPM:String name="Icon" value="/usr/share/icons/topics/news_newspaper.gif" xmlmultiple="true"/>
</QPM:Launch>

</QPG:PackageFilter>

</QPG:Values>
</QPG:Generation>

Jerry Chappell

Re: packager won't pick up Script and Launch from *.qpg

Post by Jerry Chappell » Thu Jan 23, 2003 12:49 pm

Could you please post the entire QPG file for me to check? Maybe even post
the QPM files that were generated by packager? You can send directly to me
if you prefer not to post this information.

One thing I did notice is that the
<QPM:ProductInstallationProcedure>
line should not have xmlmultiple="true" as you want the block to be merged
into the existing InstallationProcedure block.

Jerry Chappell
jchappell@qnx.com

<kabe@sra-tohoku.co.jp> wrote in message news:b0n4eb$82c$1@inn.qnx.com...
I'm trying to make "packager" recognize the Launch Menu setups
in unattended mode, but whatever written in *.qpg
won't be picked up.

Tried <QPG:PackageFilter type="core"> etc etc but no banana.
(Strangely some other setups are picked up)

Do I have to manually answer the Launch spec every time?
--
kabe
package.qpg *excerpt* follows:

QPG:Generation
QPG:Values
QPG:PackageFilter
QPM:PackageManifest

QPM:ProductInstallationProcedure xmlmultiple="true"

QPM:Script xmlmultiple="true"

QPM:ScriptName>/usr/photon/bin/launchmenu_notify</QPM:ScriptName
QPM:ScriptTiming>Post</QPM:ScriptTiming
QPM:ScriptType>Use</QPM:ScriptType
/QPM:Script

QPM:Script xmlmultiple="true"

QPM:ScriptName>/usr/photon/bin/launchmenu_notify</QPM:ScriptName
QPM:ScriptTiming>Post</QPM:ScriptTiming
QPM:ScriptType>Unuse</QPM:ScriptType
/QPM:Script
/QPM:ProductInstallationProcedure
/QPM:PackageManifest

QPM:Launch name="mnews" xmlmultiple="true"
QPM:String name="Topic" value="Application/Internet"
xmlmultiple="true"/
QPM:String name="Command" value="pterm mnews"
xmlmultiple="true"/
QPM:String name="Icon" value="/usr/share/icons/topics/news_ne
wspaper.gif" xmlmultiple="true"/
/QPM:Launch

/QPG:PackageFilter

/QPG:Values
/QPG:Generation

Guest

Re: packager won't pick up Script and Launch from *.qpg

Post by Guest » Fri Jan 24, 2003 9:08 pm

I'm trying to make "packager" recognize the Launch Menu setups
in unattended mode, but whatever written in *.qpg
won't be picked up.
Self followup: I goofed.
Pushing with

packager -u -m packager.qpg DESTDIR

seemed to be plain wrong for advanced packaging.

packager -u packager.qpg

picked 'em up correctly, smooth and clear.

(Specifying only *.qpr isn't mentioned the help pages,
but is in "use packager" output.
Request help document update.)

Yes, yes, this _was_ already mentioned in the tech articles
//www.qnx.com/developer/articles/sep1401/
--
kabe

Post Reply

Return to “qdn.public.qnxrtp.devtools”