quiet mode for archiver

bridged with qdn.public.qnxrtp.devtools
Post Reply
Bill Caroselli

quiet mode for archiver

Post by Bill Caroselli » Wed Oct 29, 2003 6:20 pm

I'm building libraries with:
qcc -a my_lib $OBJS

Often there are many object files to archive. For each file it
displays an 'a' or 'r' and the file name. Can I supress this?

I tried removing the 'v' from the ARFLAGS in the makefile.
It has not affect.

Colin Burgess

Re: quiet mode for archiver

Post by Colin Burgess » Wed Oct 29, 2003 7:29 pm

qcc just invokes ar, so you could just do

ar cr archive $OBJS

Bill Caroselli <qtps@earthlink.net> wrote:
I'm building libraries with:
qcc -a my_lib $OBJS

Often there are many object files to archive. For each file it
displays an 'a' or 'r' and the file name. Can I supress this?

I tried removing the 'v' from the ARFLAGS in the makefile.
It has not affect.
--
cburgess@qnx.com

Bill Caroselli

Re: quiet mode for archiver

Post by Bill Caroselli » Wed Oct 29, 2003 7:29 pm

This did work. Thanks.

Why does qcc turn on verbose '-v' even though I did not include it in
my $(ARFLAGS)?


Colin Burgess <cburgess@qnx.com> wrote:
CB > qcc just invokes ar, so you could just do

CB > ar cr archive $OBJS

CB > Bill Caroselli <qtps@earthlink.net> wrote:
I'm building libraries with:
qcc -a my_lib $OBJS

Often there are many object files to archive. For each file it
displays an 'a' or 'r' and the file name. Can I supress this?

I tried removing the 'v' from the ARFLAGS in the makefile.
It has not affect.

Colin Burgess

Re: quiet mode for archiver

Post by Colin Burgess » Wed Oct 29, 2003 10:01 pm

'cos I'm a dummy... :v)

That should be fixed...

Bill Caroselli <qtps@earthlink.net> wrote:
This did work. Thanks.

Why does qcc turn on verbose '-v' even though I did not include it in
my $(ARFLAGS)?
Colin Burgess <cburgess@qnx.com> wrote:
CB > qcc just invokes ar, so you could just do

CB > ar cr archive $OBJS

CB > Bill Caroselli <qtps@earthlink.net> wrote:
I'm building libraries with:
qcc -a my_lib $OBJS

Often there are many object files to archive. For each file it
displays an 'a' or 'r' and the file name. Can I supress this?

I tried removing the 'v' from the ARFLAGS in the makefile.
It has not affect.

--
cburgess@qnx.com

Bill Caroselli

Re: quiet mode for archiver

Post by Bill Caroselli » Thu Oct 30, 2003 1:37 pm

Thank Colin. That made my morning.
It's nice to see some refreshing honesty.

(Now I just have to go get the coffee out of my shirt!)


Colin Burgess <cburgess@qnx.com> wrote:
CB > 'cos I'm a dummy... :v)
CB > That should be fixed...

CB > Bill Caroselli <qtps@earthlink.net> wrote:
This did work. Thanks.

Why does qcc turn on verbose '-v' even though I did not include it in
my $(ARFLAGS)?

Post Reply

Return to “qdn.public.qnxrtp.devtools”