CVS for QNX 6

bridged with qdn.public.qnxrtp.applications
Post Reply
Jim Lambert

CVS for QNX 6

Post by Jim Lambert » Thu Dec 13, 2001 10:26 pm

Anyone know where I can get this application? I tried to go to the old
qnxstart site but it was down.

TIA,

Jim

Alain Bonnefoy

Re: CVS for QNX 6

Post by Alain Bonnefoy » Fri Dec 14, 2001 9:55 am

Jim Lambert a écrit :
Anyone know where I can get this application? I tried to go to the old
qnxstart site but it was down.

TIA,

Jim
I suppose that it belongs to the development package.

regards,
Alain.

Jim Lambert

Re: CVS for QNX 6

Post by Jim Lambert » Fri Dec 14, 2001 4:52 pm

I found the 'cvs' command in QNX but I have since decided I'll just use
Samba and WinCVS.

Thanks,

Jim

"Alain Bonnefoy" <alain.bonnefoy@icbt.com> wrote in message
news:3C19CC93.357A8551@icbt.com...
Jim Lambert a écrit :

Anyone know where I can get this application? I tried to go to the old
qnxstart site but it was down.

TIA,

Jim

I suppose that it belongs to the development package.

regards,
Alain.

Alain Bonnefoy

Re: CVS for QNX 6

Post by Alain Bonnefoy » Mon Dec 17, 2001 7:18 am

Jim Lambert a écrit :
I found the 'cvs' command in QNX but I have since decided I'll just use
Samba and WinCVS.

Thanks,

Jim

"Alain Bonnefoy" <alain.bonnefoy@icbt.com> wrote in message
news:3C19CC93.357A8551@icbt.com...
Jim Lambert a écrit :

Anyone know where I can get this application? I tried to go to the old
qnxstart site but it was down.

TIA,

Jim

I suppose that it belongs to the development package.

regards,
Alain.

That doesn't change anything, you need cvs running on your qrtp machine as
server side becauseWinCVS is only the client side.
Maybe you know what to do, but in case, to get it working, you need to do the
following:

in /etc/services, add:
pserver 2401/tcp

in /etc/inetd.conf, add:
pserver stream tcp nowait root /usr/bin/cvs cvs -f
--allow-root=/anypath/CVSRoot --allow-root=/anypath/anyotherCVSRoot pserver


And for sure, start inetd or slay -shup inetd if it's still running.

In WinCVS,
as CVSROOT, enter:
:pserver:your.logname@your_qrtp_machine_name:/anypath/CVSRoot

as Authentification, enter:
"passwd file" on the cvs server

As 'Use version', choose:
cvs1.10 (standard).


Hope this will help.

regards,
Alain.

Jim Lambert

Re: CVS for QNX 6

Post by Jim Lambert » Mon Dec 17, 2001 8:07 am

Thanks but I was looking for a graphical CVS front end for QNX. Our CVS
server is on Linux. I've got samba and wincvs working and just check out my
projects to my qnx machine using samba.

Thanks for the help though, it is very much appreciated.

Jim

"Alain Bonnefoy" <alain.bonnefoy@icbt.com> wrote in message
news:3C1D9C5D.A452C41@icbt.com...
Jim Lambert a écrit :

I found the 'cvs' command in QNX but I have since decided I'll just use
Samba and WinCVS.

Thanks,

Jim

"Alain Bonnefoy" <alain.bonnefoy@icbt.com> wrote in message
news:3C19CC93.357A8551@icbt.com...
Jim Lambert a écrit :

Anyone know where I can get this application? I tried to go to the
old
qnxstart site but it was down.

TIA,

Jim

I suppose that it belongs to the development package.

regards,
Alain.



That doesn't change anything, you need cvs running on your qrtp machine as
server side becauseWinCVS is only the client side.
Maybe you know what to do, but in case, to get it working, you need to do
the
following:

in /etc/services, add:
pserver 2401/tcp

in /etc/inetd.conf, add:
pserver stream tcp nowait root /usr/bin/cvs cvs -f
--allow-root=/anypath/CVSRoot --allow-root=/anypath/anyotherCVSRoot
pserver


And for sure, start inetd or slay -shup inetd if it's still running.

In WinCVS,
as CVSROOT, enter:
:pserver:your.logname@your_qrtp_machine_name:/anypath/CVSRoot

as Authentification, enter:
"passwd file" on the cvs server

As 'Use version', choose:
cvs1.10 (standard).


Hope this will help.

regards,
Alain.

Dave Latter

Re: CVS for QNX 6

Post by Dave Latter » Wed Aug 13, 2003 6:26 pm

Alain Bonnefoy <alain.bonnefoy@icbt.com> wrote:
AB > That doesn't change anything, you need cvs running on your qrtp machine as
AB > server side becauseWinCVS is only the client side.
AB > Maybe you know what to do, but in case, to get it working, you need to do the
AB > following:

AB > in /etc/services, add:
AB > pserver 2401/tcp

AB > in /etc/inetd.conf, add:
AB > pserver stream tcp nowait root /usr/bin/cvs cvs -f
AB > --allow-root=/anypath/CVSRoot --allow-root=/anypath/anyotherCVSRoot pserver


AB > And for sure, start inetd or slay -shup inetd if it's still running.

AB > In WinCVS,
AB > as CVSROOT, enter:
AB > :pserver:your.logname@your_qrtp_machine_name:/anypath/CVSRoot

AB > as Authentification, enter:
AB > "passwd file" on the cvs server

AB > As 'Use version', choose:
AB > cvs1.10 (standard).


AB > Hope this will help.

I know this is an old post but I'm hoping that someone can help me
finish of the documentation.

My goal is to get CVS working in server mode on my QNX RTP host. I'd
like to be able to access it from the IDE.

I edited /etc/services & /etc/inetd.conf as indicated above.
I restarted inetd. Now the IDE recognizes that there is something
there that it can't connect to. (As opposed to before when there was
nothing there and I got a different error.)

BTW, I manually created the /anypath/CVSRoot directory. Is this OK?
What permissions should that directory have?

It's the In WinCVS down part that I don't know how to translate to QNX. Can someone help set up the authentication?

Dave

Rennie Allen

Re: CVS for QNX 6

Post by Rennie Allen » Thu Aug 14, 2003 2:01 pm

Dave Latter wrote:
I know this is an old post but I'm hoping that someone can help me
finish of the documentation.

My goal is to get CVS working in server mode on my QNX RTP host. I'd
like to be able to access it from the IDE.
Firstly, CVS is a third party application, which is why there are no CVS docs in
the IDE docs. Setting up the IDE to use a working CVS install is trivial
(certainly it is much easier than setting up WinCVS).
I edited /etc/services & /etc/inetd.conf as indicated above.
I restarted inetd. Now the IDE recognizes that there is something
there that it can't connect to. (As opposed to before when there was
nothing there and I got a different error.)
Again, the IDE assumes that there is a correctly configured CVS server.
BTW, I manually created the /anypath/CVSRoot directory. Is this OK?
What permissions should that directory have?
What you need to do is google for CVS. There is a lot of information about
setting up CVS on the web (any tutorial on setting it up under Linux should
translate directly to setting it up under QNX). Once your CVS server is up an
operational (use WinCVS as the client, if you are comfortable with that), then
try and connect the IDE to it. I think you will be pleasantly surprised at how
easily the IDE CVS client sets-up compared with (say) WinCVS.
It's the In WinCVS down part that I don't know how to translate to QNX. Can someone help set up the authentication?
Open the CVS perspective, create a new repository; tell it where your CVS server
is, and what your user id and password is, and your done.

Your problems seem to be related to getting the CVS server up and correctly
configured. This is probably not the best place to be seeking assistance on that.

Rennie

Dave Latter

Re: CVS for QNX 6

Post by Dave Latter » Thu Aug 14, 2003 3:01 pm

For those who care, I figured this out. It wasn't all that difficult.
I wrote down some easy to follow instructions in a new thread. Look
for "Setting up CVS" in this newsgroup.


Rennie Allen <rgallen@attbi.com> wrote:
RA > Dave Latter wrote:
I know this is an old post but I'm hoping that someone can help me
finish of the documentation.

My goal is to get CVS working in server mode on my QNX RTP host. I'd
like to be able to access it from the IDE.
RA > Firstly, CVS is a third party application, which is why there are no CVS docs in
RA > the IDE docs. Setting up the IDE to use a working CVS install is trivial
RA > (certainly it is much easier than setting up WinCVS).
I edited /etc/services & /etc/inetd.conf as indicated above.
I restarted inetd. Now the IDE recognizes that there is something
there that it can't connect to. (As opposed to before when there was
nothing there and I got a different error.)
RA > Again, the IDE assumes that there is a correctly configured CVS server.
BTW, I manually created the /anypath/CVSRoot directory. Is this OK?
What permissions should that directory have?
RA > What you need to do is google for CVS. There is a lot of information about
RA > setting up CVS on the web (any tutorial on setting it up under Linux should
RA > translate directly to setting it up under QNX). Once your CVS server is up an
RA > operational (use WinCVS as the client, if you are comfortable with that), then
RA > try and connect the IDE to it. I think you will be pleasantly surprised at how
RA > easily the IDE CVS client sets-up compared with (say) WinCVS.
It's the In WinCVS down part that I don't know how to translate to QNX. Can someone help set up the authentication?
RA > Open the CVS perspective, create a new repository; tell it where your CVS server
RA > is, and what your user id and password is, and your done.

RA > Your problems seem to be related to getting the CVS server up and correctly
RA > configured. This is probably not the best place to be seeking assistance on that.

RA > Rennie

Post Reply

Return to “qdn.public.qnxrtp.applications”