cvs bug?

bridged with qdn.public.qnxrtp.applications
Post Reply
Daniel Masalski

cvs bug?

Post by Daniel Masalski » Fri Feb 15, 2002 1:37 pm

Hi,

I'm trying to use cvs in pserver mode under QNX RTP 6.1.0A and can't get rid
of these messages:

cvs server: cannot open /root/.cvsignore: Permission denied
cvs [server aborted]: can't chdir(/root): Permission denied

I've configured "cvspserver tcp/2401" in /etc/services and "cvspserver ...
/usr/bin/cvs cvs -f --allow-root=xxx pserver" in /etc/inetd.conf.
It is stated in docs that '-f' prevents cvs from looking for rc files in
home directory (/root in that case).
But it doesn't seem to work this way (it has no effect). Adding 'chmod a+r
/root' fixes (sic!) it.

I've tried it under Linux and without '-f' there is same result but running
"cvs -f ... pserver" makes it work ok.

Is there anything I'm doing wrong or it is a bug ?

Daniel

Dave Latter

Re: cvs bug?

Post by Dave Latter » Thu Aug 14, 2003 5:50 pm

Has this been resolved?
I'm having the same problem.

Daniel Masalski <daniel@autocomp.com.pl> wrote:
DM > Hi,

DM > I'm trying to use cvs in pserver mode under QNX RTP 6.1.0A and can't get rid
DM > of these messages:

DM > cvs server: cannot open /root/.cvsignore: Permission denied
DM > cvs [server aborted]: can't chdir(/root): Permission denied

DM > I've configured "cvspserver tcp/2401" in /etc/services and "cvspserver ...
DM > /usr/bin/cvs cvs -f --allow-root=xxx pserver" in /etc/inetd.conf.
DM > It is stated in docs that '-f' prevents cvs from looking for rc files in
DM > home directory (/root in that case).
DM > But it doesn't seem to work this way (it has no effect). Adding 'chmod a+r
DM > /root' fixes (sic!) it.

DM > I've tried it under Linux and without '-f' there is same result but running
DM > "cvs -f ... pserver" makes it work ok.

DM > Is there anything I'm doing wrong or it is a bug ?

DM > Daniel




--
Bill Caroselli -- Q-TPS Consulting
1-(626) 824-7983
qtps@earthlink.net

Post Reply

Return to “qdn.public.qnxrtp.applications”